Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52333 - [gdk-pixbuf2] 2.36.1+31+gecea71eb6-1 cannot load png file

Attached to Project: Arch Linux
Opened by Yang Yang (reliveyy) - Monday, 02 January 2017, 13:32 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 02 January 2017, 20:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
https://www.archlinux.org/packages/extra/x86_64/gdk-pixbuf2/

gdk-pixbuf2 2.36.1+31+gecea71eb6-1 cannot load png file and that leads to a fail loading of awesome WM
https://github.com/awesomeWM/awesome/issues/1349

Steps to reproduce:

Test code: (test.c)
#include <gdk-pixbuf/gdk-pixbuf.h>
#include <stdio.h>

int main(int argc, char *argv[]) {
int files = argc-1;
int cur;

for (cur = 1; cur < argc; cur++) {
GdkPixbuf *pbuf;
GError *error = NULL;

printf("Trying to load '%s'...", argv[cur]);
pbuf = gdk_pixbuf_new_from_file(argv[cur], &error);
if (pbuf != NULL) {
puts("Success");
g_object_unref(pbuf);
}
if (error != NULL) {
printf("Error: %s\n", error->message);
g_error_free(error);
}
}

printf("Done loading %d files\n", files);
return 0;
}

gcc test.c $(pkg-config --libs --cflags gdk-pixbuf-2.0) -Wall -Wextra -O3
./a.out /usr/share/awesome/themes/default/background.png

This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 02 January 2017, 20:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  gdk-pixbuf2 2.36.2
Comment by Doug Newgard (Scimmia) - Monday, 02 January 2017, 15:32 GMT
Except it's not built without png support, it's built with png support statically linked instead of as a module. I was troubleshooting this earlier on IRC and built the package with png support as a module and it made no difference.

I cannot reproduce with your example.
Comment by Yang Yang (reliveyy) - Monday, 02 January 2017, 15:50 GMT
After I installed xfce4 the problem is fixed automaticlly. The environment before I installed xfce4 is
* new archlinux on VirtualBox
* xorg (all) xorg-xinit xorg-server xorg-server-utils
* virtualbox-guest-utils
* xterm
* xf86-video-vesa
* awesome
Comment by Doug Newgard (Scimmia) - Monday, 02 January 2017, 15:52 GMT
Are you the same guy from IRC that was having this issue? He was on VirtualBox as well and had installed the entire xorg group (which you should not do).

So it appears to be some missing dependency.
Comment by Yang Yang (reliveyy) - Monday, 02 January 2017, 15:53 GMT
Maybe. I only report this issue on IRC and someone tell me to fire a bug report. That's all.
Comment by Doug Newgard (Scimmia) - Monday, 02 January 2017, 16:03 GMT
Not the same guy, then. We know at least 2 people have run into this. :(
Comment by Doug Newgard (Scimmia) - Monday, 02 January 2017, 17:40 GMT
Awesome upstream has pointed this out: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=801170

Could be the same issue.

Edit: someone on IRC just confirmed it. Missing dep on shared-mime-info.
Comment by Jan Alexander Steffens (heftig) - Monday, 02 January 2017, 19:48 GMT
Technically it's glib which consumes the mime info, and gdk-pixbuf just uses glib's type sniffing. But adding the dep to glib2 would create a circular dep.

Loading...