Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52316 - [cinnamon-screensaver] 3.2.13-1 requires python-setproctitle as dependency

Attached to Project: Community Packages
Opened by lxhillwind (lxhillwind) - Saturday, 31 December 2016, 06:54 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 04 January 2017, 15:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
python-setproctitle is not installed as dependency by default. After upgrade cinnamon-screensaver to 3.2.13-1, screensaver won't work.

Additional info:
* package version(s)

3.2.13-1

* config and/or log files etc.

execute cinnamon-screensaver inside terminal, output:

Traceback (most recent call last):
File "/usr/share/cinnamon-screensaver/cinnamon-screensaver-main.py", line 13, in <module>
import setproctitle
ImportError: No module named 'setproctitle'

Steps to reproduce:
make sure python-setproctitle is not installed, then the bug is always here that you can't lock screen. After installing python-setproctitle and relogining, screensaver works.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 04 January 2017, 15:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  cinnamon-screensaver 3.2.13-2
Comment by - (sukosevato) - Saturday, 31 December 2016, 12:08 GMT
I can confirm that the above works. The relogin step is necessary since it won't work directly after installing the 'python-setproctitle' package.
Comment by Anish (phinfinity) - Monday, 02 January 2017, 06:27 GMT
Can also confirm bug. Was impacted by the same, and adding installing python-setproctitle works. This should be added as a dependency for the screensaver package.
Comment by Patrick Brennan (patrick.brennan) - Tuesday, 03 January 2017, 08:46 GMT
I also confirm the same having erroneously raised the duplicate  bug 52346  which can be closed (in which I assumed it was my orphan package cleanup rather than the upgrade introducing a new dependency).
Comment by Freddy (AvelVras) - Tuesday, 03 January 2017, 16:24 GMT
Hi all,
I can confirm with the bug I can't lock screen (ctrl+alt+l).
I can confirm also with python-setproctitle, the problem solved. Thanks lxhillwind
I use cinnamon 3.2.7

Happy new year at all

Loading...