Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52296 - llvm 3.9.1 causing incorrect sprites in zandronum Doom engine with Mesa

Attached to Project: Arch Linux
Opened by J. Andrew Lanz-O'Brien (jlanzobr) - Thursday, 29 December 2016, 05:14 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 31 December 2016, 19:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: LLVM 3.9.1 causes sprites in Zandronum to have a black rectangular background instead of a transparent background. Downgrading to 3.9.0 fixes the issue. Specifically, I downgraded clang, lib32-clang, lib32-llvm, lib32-llvm-libs, llvm, and llvm-libs to 3.9.0-3 from 3.9.1-1 and the issue was resolved.


Additional info:
Running Mesa 13.0.2-1 on a Radeon R9-280.
My Broadwell laptop with Intel integrated graphics is NOT affected, this seems to be limited to AMD graphics with LLVM/Mesa as far as I can test.


Steps to reproduce:
1. Have a Radeon graphics card using Mesa
2. Install zandronum-hg or zandronum2 from the AUR and observe the black backgrounds on sprites. Also happens with Zandronum 2 running in WINE.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 31 December 2016, 19:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#52288 
Comment by Doug Newgard (Scimmia) - Saturday, 31 December 2016, 15:09 GMT
Can you see if llvm-libs 3.9.1-2 fixes this? It's likely the same as  FS#52288 .
Comment by J. Andrew Lanz-O'Brien (jlanzobr) - Saturday, 31 December 2016, 16:05 GMT
Yes, 3.9.1-2 does fix it. Thank you.

Loading...