Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52271 - [linux] 4.9-1 - kernel panic on boot

Attached to Project: Arch Linux
Opened by James (thx1138) - Monday, 26 December 2016, 02:36 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 24 March 2017, 08:23 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

linux 4.9-1

kernel panic on boot. 4.8.13-1 works ok.

This happens even before the video resolution has been reset.
Some acpi calls are visible in the stack trace on the screen.

This is on a Toshiba Satellite L655, with a Pentium P6200, Intel chipset and graphics.

I don't know what else I can say at this point. Let me know if there are additional tests to try.


This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 24 March 2017, 08:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.10.1-1
Comment by James (thx1138) - Monday, 26 December 2016, 17:54 GMT
Ok, I tried booting with acpi=off on the command line, and yes, it does then boot without crashing, though this makes a mess of things. For instance, the screen resolution is not set, and the network interface names change, breaking network init.
Comment by James (thx1138) - Monday, 26 December 2016, 18:56 GMT
Also panics with acpi=ht.

At https://01.org/linux-acpi/documentation/debug-how-isolate-linux-acpi-issues

"If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code."

BTW, Toshiba has a special module, toshiba_acpi.
Comment by James (thx1138) - Monday, 26 December 2016, 20:33 GMT
Documentation/kernel-parameters.txt makes no mention of "acpi=ht", so that may not work or mean anything any more.
Comment by Frederic Bezies (fredbezies) - Friday, 06 January 2017, 12:43 GMT
Seems to be the same as  bug 52246  ; will try to boot using acpi=off and report asap.
Comment by James (thx1138) - Saturday, 07 January 2017, 23:52 GMT
There are no acpi updates in linux 4.9.1, and so the kernel panic on boot is still there.
Comment by Frederic Bezies (fredbezies) - Monday, 09 January 2017, 17:51 GMT
And not in 4.9.2 too. By the way, with acpi=off I can get it boot, but there is no working xorg display :(
Comment by Frederic Bezies (fredbezies) - Tuesday, 10 January 2017, 09:52 GMT
Can we revert this patch and see if it boots correctly?

https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=a035dc674dd477e61e5b917c60c30622b6d083f8

Found on this forum thread :

https://bbs.archlinux.org/viewtopic.php?id=221538

Another upstream bug closed as unreproducible :

https://bugzilla.kernel.org/show_bug.cgi?id=188221

Or apply / revert the patch found in this bug report?

Edit : Applied it, build a kernel and still no luck :(
Comment by Frederic Bezies (fredbezies) - Wednesday, 11 January 2017, 13:15 GMT
Reverting the commit https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=8b355e3bc1408be238ae4695fb6318ae502cae8e seems to work, at least for my intel based laptop.

Looks like there could be a patch for linux 4.10-rc4 : https://bugzilla.kernel.org/show_bug.cgi?id=192111#c13
Comment by James (thx1138) - Monday, 27 February 2017, 19:26 GMT
I see linux 4.10.1-1 working normally on the Toshiba Satellite L655.

https://bugzilla.kernel.org/show_bug.cgi?id=192111#c31 says "it is in v4.9.6 and newer."

Thanks Frederic.

Loading...