Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52267 - Ansible package is running on python 3 which breaks some uncompatible modules (like ufw)

Attached to Project: Community Packages
Opened by Shahin Azad (shahinism) - Sunday, 25 December 2016, 16:58 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 25 December 2016, 17:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Some Ansible modules are not developed using python3 compatible syntax and currently running ansible on python3 will break them with errors like:

FAILED! => {
"changed": false,
"failed": true,
"invocation": {
"module_name": "ufw"
},
"module_stderr": "Traceback (most recent call last):\n File \"/tmp/ansible_bl5vil0y/ansible_module_ufw.py\", line 296, in <module>\n main()\n File \"/tmp/ansible_bl5vil0y/ansible_module_ufw.py\", line 249, in main\n for (command, value) in commands.iteritems():\nAttributeError: 'dict' object has no attribute 'iteritems'\n$
}


Additional info:
* package version(s)

➜ ansible ansible --version
ansible 2.2.0.0
config file = /home/shahin/Workspace/Experiment/ansible/ansible.cfg
configured module search path = Default w/o overrides
➜ ansible python --version
Python 3.5.2
➜ ansible python2 --version
Python 2.7.12

* config and/or log files etc.


Steps to reproduce:

Create and execute following playbook to see the failure:

- hosts: all
become: true
tasks:
- ufw:
logging: on

This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 25 December 2016, 17:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Configuration issue. Read the wiki or the upstream faq.

Loading...