Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52249 - lvm2-lvmetad.socket delays shutdown/reboot

Attached to Project: Arch Linux
Opened by fridi (fridi) - Friday, 23 December 2016, 10:01 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 23 December 2016, 15:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

During shutdown or reboot the system freezes for about 2-3 minutes. Disabling lvmetad in /etc/lvm/lvm.conf, disabling lvm2-lvmetad.service and masking lvm2-lvmetad.socket solved the issue. It only happens on my desktop, which has two hdd's with a mirrored raid1 logical volume on them. My laptop, with regular logical volumes, does not have the issue. I do not know if the issue applies when the mirrored volume is not the root.

lvm2 2.02.168-1
systemd 232-6

Steps to reproduce:

Install Arch on a mirrored (raid1) logical volume with the default options.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 23 December 2016, 15:21 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#50420
Comment by nl6720 (nl6720) - Friday, 23 December 2016, 14:06 GMT
Looks like a duplicate of FS#50420 ?
Try enabling and starting lvm2-monitor.service
Comment by fridi (fridi) - Friday, 23 December 2016, 15:03 GMT
Looks a duplicate indeed, although the focus is different. It seems the problem is lvmetad ignores SIGTERM. I'll report it upstream. I do not really need lvmetad however, so it's already resolved for me.

Loading...