Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52189 - [xorg-server] X server frequently freezing

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Saturday, 17 December 2016, 13:56 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 11 January 2017, 18:11 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

X completely froze 4 times, requiring a reboot, within the first 15 minutes of installing xorg-server 1.19.0-3 from testing. Usually happened when opening a new application window--the window borders would render but no window content. Mouse cursor would still move but could not click on anything.

Downgrading to the version from extra (1.18.4-1) appears to have fixed the problem.

Additional info:
* package version(s)

linux 4.8.13-1
xorg-server-1.19.0-3
xf86-video-intel 1:2.99.917+746+g169c74f-2
mesa 13.0.2-2
xfwm4 4.12.3-2
compton 0.1_beta2.5-4

* config and/or log files etc.

Using DRI2 (but probably irrelevant?)

Steps to reproduce:

1. Boot up the system.
2. Start any graphical application.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 11 January 2017, 18:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  xorg-server-1.19.0-6
Comment by Laurent Carlier (lordheavy) - Saturday, 17 December 2016, 16:40 GMT
Have you tried with modesetting driver? (you must remove xf86-video-intel package)
Comment by John Lindgren (jlindgren) - Saturday, 17 December 2016, 18:20 GMT
I have tried it. With modesetting, the system does not freeze but is utterly broken in other ways (wrong resolution, parts of the screen shifted/duplicated, and dual-head unusable). I believe this is due to mesa/DRI3 bugs since xf86-video-intel has the same issues if DRI3 is enabled.
Comment by Laurent Carlier (lordheavy) - Saturday, 17 December 2016, 18:58 GMT
All is fine here with modesetting drivers with amdgpu (desktop) or with ivybridge (laptop).
You should fill an upstream bugreport at https://bugs.freedesktop.org and paste the link here.
Comment by John Lindgren (jlindgren) - Saturday, 17 December 2016, 19:26 GMT
That's what I did the last time and it's been three months with no fix. I realize Arch wants to ship the latest, but when the latest means a broken graphics stack, again and again, that upstream can't be bothered to test before releasing, I'm just not interested any more. I'll downgrade for now and probably switch to a more stable distro eventually.
Comment by John Lindgren (jlindgren) - Saturday, 17 December 2016, 19:27 GMT
Here are two upstream reports I have open already that are just languishing:
https://bugs.freedesktop.org/show_bug.cgi?id=97914
https://bugs.freedesktop.org/show_bug.cgi?id=97916
Comment by John Lindgren (jlindgren) - Saturday, 17 December 2016, 19:51 GMT
Also, there are reports of lockups on ATI and nvidia cards so this doesn't seem to be an Intel-specific issue, but something more general with Xorg 1.19.

https://bbs.archlinux.org/viewtopic.php?pid=1676455
https://bugs.archlinux.org/task/52157
Comment by Andreas Radke (AndyRTR) - Tuesday, 20 December 2016, 19:14 GMT
Someone affected please talk to Xorg devs at #xorg or #xorg-devel and look for a generic Xorg 1.19 upstream bug or file one.
Comment by Mantas Mikul─Śnas (grawity) - Sunday, 25 December 2016, 17:09 GMT
I'm wondering if https://git.kernel.org/linus/1c4672ce4eeaeaadeea8adabaad21262b7172607 might have anything to do with the hangs
Comment by Laurent Carlier (lordheavy) - Thursday, 05 January 2017, 20:23 GMT
Is it with xf86-input-libinput driver?
Comment by John Lindgren (jlindgren) - Friday, 06 January 2017, 07:19 GMT
I am using the libinput driver (evdev is not installed). The Haswell/Broadwell fix linked two comments above is probably not related since mine is an Ivy Bridge system.
Comment by Bastian Beranek (totsilence) - Tuesday, 10 January 2017, 08:44 GMT Comment by Laurent Carlier (lordheavy) - Tuesday, 10 January 2017, 20:46 GMT
please test with xorg-server-1.19.0-6
Comment by Bastian Beranek (totsilence) - Wednesday, 11 January 2017, 09:22 GMT
Works for me Laurent, thanks!
Comment by John Lindgren (jlindgren) - Wednesday, 11 January 2017, 17:38 GMT
Seems to be fixed here as well, thank you!

Loading...