Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52175 - [php-apcu] Needs to rebuilt to use new API

Attached to Project: Arch Linux
Opened by Francois (francoism90) - Friday, 16 December 2016, 13:06 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 16 December 2016, 14:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
It doesn't seem to work, need to manually download the tarball, and run makepkg so the API's match.
After rebuild:
Dec 16 14:01:08 nas1 systemd[1]: Starting The PHP FastCGI Process Manager...
Dec 16 14:01:08 nas1 systemd[1]: Started The PHP FastCGI Process Manager.

Additional info:
* php
* php-fpm
* nginx

Steps to reproduce:
* Install php-apcu

See log with php-fpm when not rebuild:
Dec 16 13:58:33 nas1 systemd[1]: Starting The PHP FastCGI Process Manager...
Dec 16 13:58:34 nas1 php-fpm[32006]: [16-Dec-2016 13:58:34] NOTICE: PHP message: PHP Warning: PHP Startup: apcu: Unable to initialize module
Dec 16 13:58:34 nas1 php-fpm[32006]: Module compiled with module API=20151012
Dec 16 13:58:34 nas1 php-fpm[32006]: PHP compiled with module API=20160303
Dec 16 13:58:34 nas1 php-fpm[32006]: These options need to match
Dec 16 13:58:34 nas1 php-fpm[32006]: in Unknown on line 0

Thanks.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 16 December 2016, 14:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial updates are not supported.

Ah! I've disabled the [testing] repo, before installing php-apcu. Still had the php packages of the testing. Sorry, bug can be closed.
Comment by Doug Newgard (Scimmia) - Friday, 16 December 2016, 13:10 GMT
What version of php?
Comment by Francois (francoism90) - Friday, 16 December 2016, 13:26 GMT
Official package (php7), it seems to be compatible.
Comment by Doug Newgard (Scimmia) - Friday, 16 December 2016, 13:33 GMT
Specific information, please. There are 2 versions of php7 in the repos right now.
Comment by Francois (francoism90) - Friday, 16 December 2016, 14:25 GMT
Sorry, seems to be testing I'm using: https://www.archlinux.org/packages/testing/x86_64/php/
Comment by Doug Newgard (Scimmia) - Friday, 16 December 2016, 14:31 GMT
So you've got php from testing, is php-apcu also the version from testing?

Loading...