Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52168 - [gdk-pixbuf2] Latest package breaks various things

Attached to Project: Arch Linux
Opened by ringo de kroon (ringo32) - Thursday, 15 December 2016, 10:42 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 20 December 2016, 14:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Hexchat lost icons.Tray and in hexchat Voice and OP.

Additional info:
* package version(s)gdk2-pixbuf 2.36.1+9+gb1fbea9-1
* config and/or log files etc.


Steps to reproduce:

downgrade fix icons to normal
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 20 December 2016, 14:16 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Thursday, 15 December 2016, 14:58 GMT
This is an example of why putting git packages in the official repos is a bad idea.
https://bugzilla.gnome.org/show_bug.cgi?id=776004
https://bbs.archlinux.org/viewtopic.php?id=220697
Comment by Jan Alexander Steffens (heftig) - Thursday, 15 December 2016, 15:22 GMT
FTR this bug was introduced pre-2.36.1 so even if I had picked the release commit we would be having this problem.

The additional commits are some crash fixes that I thought would be nice to have.
Comment by Scott (firecat53) - Thursday, 15 December 2016, 16:25 GMT
Also breaks keepassx2:

(keepassx2:10471): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(keepassx2:10471): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(keepassx2:10471): GLib-ERROR **: gmem.c:328: overflow allocating 18446744073709551615*18446744073709551615 bytes
Trace/breakpoint trap

Downgrading to gdk-pixbuf2-2.34.0-2 resolves the issue
Comment by Doug Newgard (Scimmia) - Thursday, 15 December 2016, 17:38 GMT
Looks like there are at least two separate issues at play here. The hexchat issue is likely related to the linked bug report and broken in 2.36.1. The xfdesktop issue mentioned in the linked forum thread is separate, and related to a commit since 2.36.1. Not sure about keepassx2.
Comment by TingPing (TingPing) - Thursday, 15 December 2016, 20:14 GMT Comment by patrick (potomac) - Saturday, 17 December 2016, 23:26 GMT
this is a major bug, the severity should be raised it to high, because a lot of applications crash ( thunderbird, gimp ) if we click on the bar menu,

downgrading to gdk-pixbuf2-2.36.0+2+ga7c869a-3 solves the problem

Comment by Scott (firecat53) - Saturday, 17 December 2016, 23:42 GMT
Sorry, gdk-pixbuf2-2.36.0+2+ga7c869a-3 also fixes the keepassx2 crash...don't need to go all the way down to 2.34.0.
Comment by patrick (potomac) - Saturday, 17 December 2016, 23:49 GMT
I think this bug should have been detected during the testing step, it's not normal to see this package version in extra
Comment by TingPing (TingPing) - Sunday, 18 December 2016, 01:13 GMT
Here is a workaround for HexChat if anybody wants to backport it: https://github.com/hexchat/hexchat/commit/4c178782a779f013fafab476506f7d4dae372b8a
Comment by patrick (potomac) - Sunday, 18 December 2016, 05:01 GMT
it seems ok with the new version of gdk2-pixbuf2 : 2.36.1+27+g5dcc1b8da-1
Comment by ringo de kroon (ringo32) - Sunday, 18 December 2016, 12:37 GMT
mmm with that version stil no icon on systray with hexchat.

alsos op and voice isnt there icons so back to downgrade :/

https://i.imgur.com/Hq9dihN.png
Comment by ringo de kroon (ringo32) - Sunday, 18 December 2016, 12:37 GMT
forgoth to add this line : from terminal :
** (hexchat:6499): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)
Comment by patrick (potomac) - Sunday, 18 December 2016, 17:16 GMT
@ringo32: what gtk theme do you use ?

in plasma 5 bugs can occur with gdk2-pixbuf2 with some gtk2 themes ( for example with Qtcurve for gtk2 ),

you can try to change the gtk2-theme in order to see if the bug is still here
Comment by Wolf Giesen (frilled) - Monday, 19 December 2016, 14:54 GMT
No improvement with the new version using Adwaita under xfce4, still no Hexchat try/mode icons.
Comment by ringo de kroon (ringo32) - Monday, 19 December 2016, 16:24 GMT
i use Arc-themes also adapta on the switch.. both are well maintained upstream no fork..several people has this issue on hexchat not only in lxqt or kde....
Comment by Scott (firecat53) - Monday, 19 December 2016, 22:39 GMT
2.36.1+31+gecea71eb6-1 fixes whatever was crashing keepassx2
Comment by ringo de kroon (ringo32) - Tuesday, 20 December 2016, 13:48 GMT
yep 2.36.1+31+gecea71eb6-1 fixed hexchat icon.
Comment by Wolf Giesen (frilled) - Tuesday, 20 December 2016, 14:02 GMT
Agreed, 2.36.1+31+gecea71eb6-1 fixes the issue.

Loading...