Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52157 - [xorg-server] freezing video in mpv / vlc with nouveau and Xorg 1.19

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Wednesday, 14 December 2016, 19:47 GMT
Last edited by Laurent Carlier (lordheavy) - Friday, 13 January 2017, 13:01 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: I noticed that in both vlc and mpv (or gnome mpv) you cannot play a video for more than two or three minutes before it freezes. Sound goes on, but not the display. Freezes started right after last xf86-video-nouveau update.

I verified it was not a mpv or vlc bug by building nvidia 340.101 driver on my archlinux with testing enabled.


Additional info:
xf86-video-nouveau 1.0.13-2
mpv 1:0.22.0-2

Steps to reproduce: Use archlinux and testing with nouveau for your nvidia card or chipset. Launch a video and wait until picture freeze and sound is going on. I have to kill mpv using xkill
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Friday, 13 January 2017, 13:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  xorg-server-1.19.1
Comment by Mika Attila (solvedsnake) - Thursday, 15 December 2016, 14:26 GMT
It might be related to this issue: https://bbs.archlinux.org/viewtopic.php?pid=1676455

Can you try and help reproduce this? No one has confirmed it so far.

Yes, mpv also exhibits the crash for me, since it uses OpenGL for rendering.
Comment by Frederic Bezies (fredbezies) - Thursday, 15 December 2016, 15:24 GMT
I did not get any crash, just a freeze.

I looked at which dri is used :

[fred@fredo-arch ~]$ cat /var/log/Xorg.0.log | grep DRI
[ 15.774] (==) NOUVEAU(0): Allowed maximum DRI level 2.
[ 15.903] (II) NOUVEAU(0): [DRI2] Setup complete
[ 15.903] (II) NOUVEAU(0): [DRI2] DRI driver: nouveau
[ 15.903] (II) NOUVEAU(0): [DRI2] VDPAU driver: nouveau
[ 16.987] (II) GLX: Initialized DRI2 GL provider for screen 0

glxgears hanged after a minute or so.

Looks like debian bug is nailing the problem. By the way, even with last xorg-server, opengl rendering is hanging... :(

[fred@fredo-arch ~]$ pacman -Qi xorg-server
Name : xorg-server
Version : 1.19.0-3
Description : Xorg X server
Architecture : x86_64
URL : http://xorg.freedesktop.org
Licenses : custom
Groups : xorg
Provides : X-ABI-VIDEODRV_VERSION=23 X-ABI-XINPUT_VERSION=24.1
X-ABI-EXTENSION_VERSION=10.0 x-server
Depends On : libepoxy libxfont2 pixman xorg-server-common libunwind
dbus libgl xf86-input-libinput
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : nvidia-utils<=331.20 glamor-egl xf86-video-modesetting
Replaces : glamor-egl xf86-video-modesetting
Installed Size : 3.55 MiB
Packager : Andreas Radke <andyrtr@archlinux.org>
Build Date : Thu Dec 15 13:13:25 2016
Install Date : Thu Dec 15 15:51:56 2016
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature
Comment by Frederic Bezies (fredbezies) - Thursday, 22 December 2016, 22:47 GMT
Deactivating compositing - I had to "downgrade" to nouveau, nvidia-340xx is not working with linux 4.9 -> https://bugs.archlinux.org/task/52243 - and I will report if it still freeze or not.
Comment by Frederic Bezies (fredbezies) - Friday, 23 December 2016, 09:13 GMT
Deactivating window compositing in Mate Desktop doesn't change anything :(
Comment by Frederic Bezies (fredbezies) - Friday, 06 January 2017, 12:02 GMT
Last xorg-server in testing - 1.19.0-4 - still doesn't fix this bug :(

Had to install again legacy nvidia driver.
Comment by Luke (slacka) - Friday, 13 January 2017, 01:41 GMT
No issues with mpv, vlc, or glxgears on GK107 [GeForce GTX 650].

$ pacman -Qi xorg-server
Name : xorg-server
Version : 1.19.1-1

$ glxinfo |grep -i opengl
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NVE7
OpenGL core profile version string: 4.3 (Core Profile) Mesa 13.0.3

Can you please test again with 1.19.1. If you still have issues can you file a bug report upstream?
Comment by Frederic Bezies (fredbezies) - Friday, 13 January 2017, 12:42 GMT
Indeed, xorg-server 1.19.1 is not showing this bug anymore. Maybe some commits added fixes this annoying bug? Can bug be closed, now?

Thanks for the info, Luke.

Loading...