Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52143 - [filesystem] nsswitch.conf breaks some postfix configurations

Attached to Project: Arch Linux
Opened by Sergej Pupykin (sergej) - Wednesday, 14 December 2016, 00:06 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 14 December 2016, 14:44 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrade postfix report "error looking up passwd info for ..." + "user lookup error" and fails to deliver mail through mailbox_transport. My configuration uses LDAP amd dbmail, so there is no local user which systemd may know. Probably it returns another error code which treated by postfix as fatal.

Reverting "passwd", "group", "shadow" to "files" fixes the problem.

I think it should print huge notice at least about such dramatic change in post_upgrade().

PS. Actualy I am not sure if it was systemd, but usualy it causes most of problems :)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 14 December 2016, 14:44 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#51709 

We're keeping the discussion together
Comment by Daniel M. Capella (polyzen) - Wednesday, 14 December 2016, 03:27 GMT
Seems to be a duplicate of  FS#51709 
Comment by Sergej Pupykin (sergej) - Wednesday, 14 December 2016, 06:56 GMT
filesystem version is 2016.12-2:

[2016-12-13 18:19] [ALPM] upgraded filesystem (2015.09-1 -> 2016.12-2)

Loading...