Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52105 - [gcc] c++ broken on i686

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Saturday, 10 December 2016, 14:02 GMT
Last edited by Gaetan Bisson (vesath) - Saturday, 10 December 2016, 14:23 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity High
Priority High
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On i686 I cannot compile the simplest of C++ programs:

echo 'int main () { return 0; }' > wtf.cpp
c++ wtf.cpp

results in:

<built-in>: internal compiler error: Segmentation fault
c++: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.archlinux.org/> for instructions.

All works fine if I compile the above as a C program and/or if I compile on x86_64. Is it just me?!?
This task depends upon

Closed by  Gaetan Bisson (vesath)
Saturday, 10 December 2016, 14:23 GMT
Reason for closing:  Not a bug
Comment by Gaetan Bisson (vesath) - Saturday, 10 December 2016, 14:23 GMT
Never mind, probably a corrupted disk/ram.

Loading...