Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52102 - [python-sphinx] python-requests should be added as a dependency

Attached to Project: Community Packages
Opened by larchunix (larchunix) - Saturday, 10 December 2016, 09:28 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 19 December 2016, 13:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

sphinx-build raises the following exception :

Traceback (most recent call last):
File "/usr/bin/sphinx-build", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3017, in <module>
@_call_aside
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3003, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3030, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 659, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 967, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 853, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'requests' distribution was not found and is required by Sphinx

Package python-requests should be added as a dependency in order to fix this issue.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 19 December 2016, 13:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-sphinx 1.5.1-1

Loading...