Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52067 - lightdm optional dependency xephyr does not support hard-coded flag -novtswitch

Attached to Project: Arch Linux
Opened by camden linday (thenextdon13) - Wednesday, 07 December 2016, 01:52 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 07 December 2016, 05:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
lightdm does not have any required X server dependencies.
The X server listed as an optional depenency is Xephyr.
lightdm has a hard-coded '-novtswitch' flag when run as root
lightdm.service by default runs as root to start X
Xephyr does not support this flag

lightdm has a bug report about it here:
https://bugs.launchpad.net/lightdm/+bug/852577

It would seem a different X dependency should be created perhaps?

Additional info:
* package version(s)
Light Display Manager 1.18.3
xorg-server-xephyr Version : 1.18.4-1

* config and/or log files etc.
(EE)
Fatal server error:
(EE) Unrecognized option: -novtswitch
(EE)


Steps to reproduce:
Install lightdm
Install xorg-server-xephyr
attempt to start lightdm.service
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 07 December 2016, 05:31 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 07 December 2016, 05:30 GMT
xephr is listed for "test mode". It doesn't make sense to be running it from the service.

If you want X, set up X.

Loading...