Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52060 - [hashcat] SIGILL on launch

Attached to Project: Community Packages
Opened by mickael9 (mickael9) - Tuesday, 06 December 2016, 17:20 GMT
Last edited by Levente Polyak (anthraxx) - Wednesday, 07 December 2016, 00:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm having SIGILL exceptions whenever starting hashcat:

$ hashcat
Illegal instruction (core dumped)
$ hashcat --help
Illegal instruction (core dumped)

Additional info:
* package version: 3.20-1
* GDB output:
(gdb) run
Starting program: /usr/bin/hashcat
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program received signal SIGILL, Illegal instruction.
0x0000000000461e86 in ?? ()
(gdb) bt
#0 0x0000000000461e86 in ?? ()
#1 0x0000000000402240 in ?? ()
#2 0x00007ffff763b291 in __libc_start_main () from /usr/lib/libc.so.6
#3 0x000000000040234a in ?? ()
(gdb) x/10i $rip
=> 0x461e86: shrx %rdx,%rax,%rax
0x461e8b: cmp $0x7,%edx
0x461e8e: not %rax
0x461e91: cmova %rcx,%rax
0x461e95: cmp $0x64,%edx
0x461e98: je 0x461ea2
0x461e9a: test $0x1,%al
0x461e9c: jne 0x462360
0x461ea2: cmpb $0x0,0x23(%rbx)
0x461ea6: jne 0x462150
(gdb)

I compiled the package myself and it worked fine.
This is most likely caused by the hashcat's Makefile enforcing -march=native
This task depends upon

Closed by  Levente Polyak (anthraxx)
Wednesday, 07 December 2016, 00:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.20-2

Loading...