Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#52041 - Pacman still fails when disk full, "CheckSpace" not working

Attached to Project: Pacman
Opened by Tomas Mudrunka (harvie) - Saturday, 03 December 2016, 23:06 GMT
Last edited by Allan McRae (Allan) - Wednesday, 14 March 2018, 06:00 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 5.0.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Summary and Info: I've been doing pacman -Syu and the disk was full. (single / partition). it was upgrading package "chromium" when it runed out of space. With this message:

"
...
chyba: nelze rozbalit /usr/share/icons/hicolor/16x16/apps/chromium.png (Write failed)
chyba: nelze rozbalit /usr/share/icons/hicolor/32x32/apps/chromium.png (Write failed)
chyba: nastal problém při aktualizaci chromium
chyba: nelze provést transakci
chyba: selhalo provádění transakce (transakce byla zrušena)
Vyskytly se chyby, žádné balíčky nebyly aktualizovány.
"

It's czech so i'll translate:
- list of files that cannot be extracted from package (write failed)
- "error during upgrading chromium"
- "error: cannot execute transaction"
- "error: transaction aborted"
- "there were errors, no packages were upgraded"

There are problems with this:

1.) Pacman tried to upgrade even when there was not enough space. (I have CheckSpace enabled in pacman.conf = not working)
2.) It said there were no packages upgraded, however other packages were upgraded (before it runned out of space)
3.) Even the chromium itself was partialy upgraded, so it cannot be upgraded by "pacman -S chromium" after freeing disk space. I had to use "--force", because there were orphaned files from partialy upgraded chromium.

Steps to Reproduce:

Try to upgrade packages with full disk.
This task depends upon

Closed by  Allan McRae (Allan)
Wednesday, 14 March 2018, 06:00 GMT
Reason for closing:  No response
Comment by Allan McRae (Allan) - Saturday, 03 December 2016, 23:16 GMT
What filesystem in /?
Anything else writing to / while you upgraded?

Loading...