Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52002 - [webkitgtk2] 2.4.11-1 causes icaclient-13.4-1 to segfault in /usr/lib/libjavascriptcoregtk-1.0.so.0

Attached to Project: Arch Linux
Opened by Maciej Zięba (Crocodil) - Wednesday, 30 November 2016, 08:29 GMT
Last edited by Jan de Groot (JGC) - Thursday, 01 December 2016, 19:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Yesterday I've updated my system and since then I'm not able to use the 'selfservice' program from icaclient package - it segfaults without much useful information. After some searching, it looks like the problem is the same issue that was reported and fixed in RedHat's bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1349318. Maybe the fix can be ported to Arch Linux?

I'm happy to provide more information although I do not know how to use the debugging tools.


Additional info:
* package versions: extra/webkitgtk2-2.4.11-1, aur/icaclient-13.4-1
* I'm attaching the information from gdb and dmesg shows:

[ 5253.766779] selfservice[27789]: segfault at 8 ip 00007fbc04532468 sp 00007fbbfed6df40 error 4 in libjavascriptcoregtk-1.0.so.0.16.19[7fbc03f46000+69c000]



Steps to reproduce:
* Install the packages
* Run /opt/Citrix/ICAClient/selfservice and connect to a Citrix workspace
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 01 December 2016, 19:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  Workaround is in testing.
Comment by Maciej Zięba (Crocodil) - Wednesday, 30 November 2016, 08:55 GMT
I've checked the srpm at http://koji.fedoraproject.org/koji/buildinfo?buildID=775700 and as far as I can tell, the RedHat fix was done in webkitgtk.spec file by changing the lines:


# Workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1320240
%ifarch s390 s390x ppc %{power64} aarch64 %{mips}
%global optflags %{optflags} -fno-delete-null-pointer-checks
%endif


to:


# Workaround crashes with gcc 6.1
%global optflags %{optflags} -fno-delete-null-pointer-checks
Comment by Maciej Zięba (Crocodil) - Wednesday, 30 November 2016, 11:19 GMT
I have used the latest PKGBUILD from git (2.4.11-2) and I've built it with '-fno-delete-null-pointer-checks' added to CFLAGS in /etc/makepkg.conf. After installing the package built this way, selfservice app works fine.

Loading...