Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51945 - Device LVM not found after upgrade linux-lts and readline

Attached to Project: Arch Linux
Opened by Freddy (AvelVras) - Thursday, 24 November 2016, 13:14 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 24 November 2016, 13:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi everyone,
In first, sorry for my bad english language.

Description:
After a upgrade of readline (6.3.008-4 -> 7.0-1), linux-lts (4.4.31-1 -> 4.4.34-1), lvm2 (2.02.166-1 -> 2.02.167-2) and other packages, during the building image with mkinitcpio, a problem is indicated:

[2016-11-24 11:11] [ALPM] upgraded linux-lts (4.4.31-1 -> 4.4.34-1)
[2016-11-24 11:11] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2016-11-24 11:11] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio. Please wait...
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Starting build: 4.4.34-1-lts
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [pcmcia]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [keymap]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [encrypt]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [lvm2]
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> ERROR: binary dependency `libreadline.so.6' not found for `/usr/bin/lvm'
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [resume]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [shutdown]
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Image generation successful
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Starting build: 4.4.34-1-lts
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [pcmcia]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [keymap]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [encrypt]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [lvm2]
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> ERROR: binary dependency `libreadline.so.6' not found for `/usr/bin/lvm'
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [resume]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2016-11-24 11:11] [ALPM-SCRIPTLET] -> Running build hook: [shutdown]
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2016-11-24 11:11] [ALPM-SCRIPTLET] ==> Image generation successful
[2016-11-24 11:11] [ALPM] upgraded linux-lts-headers (4.4.31-1 -> 4.4.34-1)

After a reboot, impossible to boot with linux-lts:
'
ERROR: resume: hibernation device '/dev/mapper/lvm-swap' not found
ERROR: device '/dev/mapper/lvm-root' not found. Skipping fsck
ERROR: Unable to find root device '/dev/mapper/lvm-root
You are being dropped to a recovery shell
type 'exit' to try and continue booting
sh: can't acces tty; job control turned off
[rootfs ]#
'

Thanks for help



Additional info:
* package version(s)
readline (6.3.008-4 -> 7.0-1),
linux-lts (4.4.31-1 -> 4.4.34-1),
lvm2 (2.02.166-1 -> 2.02.167-2)

* config and/or log files etc.


Steps to reproduce:
pacman -Syu
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 24 November 2016, 13:21 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#51818 

Loading...