Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51878 - [qtractor] Crash on import Midi

Attached to Project: Community Packages
Opened by Orm Finnendahl (orm) - Friday, 18 November 2016, 18:49 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 19 November 2016, 15:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

qtractor imediately segfaults if trying to import a MIDI track

Additional info:
* package version(s)

qtractor 0.7.9-1

* config and/or log files etc.

none

Steps to reproduce:

- Start qtractor
- In Menu "Track->Import Track->Midi...

qtractor segfaults immediately
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 19 November 2016, 15:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  User requested: Problem solved: qt 5.7.0 has an issue with gtk themes. Installing qt5ct and setting QT_QPA_PLATFORMTHEME=qt5ct in /etc/environment, starting qt5ct and setting "Fusion" as the theme resolved the issue.
Comment by Doug Newgard (Scimmia) - Saturday, 19 November 2016, 02:20 GMT
Logs? Backtrace? Anything useful at all?
Comment by Orm Finnendahl (orm) - Saturday, 19 November 2016, 09:15 GMT
No logs but here is the core dump. It's a little big so I'm not sure it'll go through.
Comment by Orm Finnendahl (orm) - Saturday, 19 November 2016, 09:28 GMT
The core dump was too big. Attached is a log file generated with "strace -o log.txt qtractor". After startup I immediately went to the MIDI import menu to trigger the segfault.
   log.txt (902.9 KiB)

Loading...