Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51874 - [docbook-utils] docbook-utils incompatible with perl-sgmls

Attached to Project: Arch Linux
Opened by Alexander Kempen (chron) - Friday, 18 November 2016, 10:39 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 26 November 2016, 18:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The perl script 'sgmlspl' is required by backends\{man,texi} and helpers/docbook2{man,texi}-spec.pl, and it is provided by the package perl-sgmls.

The script /usr/share/sgml/docbook/utils-0.6.14/backends/man from the package docbook-utils depends on the command sgmlspl from the package perl-sgmls, but the file in perl-sgmls is called sgmlspl.pl!


Creation of man-pages from sgml fails with:
jw -c /usr/share/sgml/docbook-sgml-4.5/catalog -b man gnome-multi-writer.sgml
Using catalogs: /etc/sgml/catalog, /usr/share/sgml/docbook-sgml-4.5/catalog
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#print
Working on: man/gnome-multi-writer.sgml
/usr/share/sgml/docbook/utils-0.6.14/backends/man: line 11: sgmlspl: command not found


Changing both appearances of 'sgmlspl' to 'sgmlspl.pl' in /usr/share/sgml/docbook/utils-0.6.14/backends/man fixes the problem.


Additional info:
*perl-sgmls 1:1.1-1
*docbook-utils 0.6.14-8
*docbook-sgml 4.5-5

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 26 November 2016, 18:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  symlink added to perl-sgmls pkg in community; 1.1-2
Comment by Jan Alexander Steffens (heftig) - Thursday, 24 November 2016, 13:10 GMT
This is hurting me too (colord and colord-gtk); please fix it.
Comment by Jan Alexander Steffens (heftig) - Thursday, 24 November 2016, 13:27 GMT
Should perl-sgmls just provide a symlink called sgmlspl?
Comment by Alexander Kempen (chron) - Thursday, 24 November 2016, 18:15 GMT
It would certainly be the simplest solution.

Loading...