Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51873 - provide symlinks for /lib/modules/<previous version>

Attached to Project: Arch Linux
Opened by Richard (archer666) - Friday, 18 November 2016, 09:05 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 18 November 2016, 15:24 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version 5.0.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

Arch updated my Kernel from 4.8.8-1-ARCH (which I am running) to 4.8.8-2-ARCH (which is on the disk)

After installing ntfs-3g, the mount failed because

# mount /mnt/winC/
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.8.8-1-ARCH
fuse: device not found, try 'modprobe fuse' first

As there is only a /lib/modules/4.8.8-2 present, I fixed the issue with

/lib/modules
# ln -s 4.8.8-2-ARCH/ 4.8.8-1-ARCH

lrwxrwxrwx 1 root root 13 Nov 18 09:53 4.8.8-1-ARCH -> 4.8.8-2-ARCH/
drwxr-xr-x 4 root root 4096 Nov 18 00:03 4.8.8-2-ARCH
drwxr-xr-x 2 root root 4096 Nov 18 00:03 extramodules-4.8-ARCH

# modprobe fuse
# mount /mnt/winC/

-> OK!

Steps to Reproduce:

1) run Kernel 4.8.8-1
2) pacman -Syu (installs 4.8.8-2)
3) do not reboot
4) install ntfs-3g (which fetches also fuse)


Proposal:

The problem may be a bug in the fuse package not recognizing correctly what is on the disk, but just assuming information from what kernel is running. Still,

when installing a new Kernel, if the version difference is only a patchlevel, provide this symbolic link.
While not being a "fix", it alleviates these kind of problems without much compatibility risk.

Basically the linux kernel install/update script could set and clean those "compatibility links".
IMHO this functionality would add to user convenience.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 18 November 2016, 15:24 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#16702
Comment by Doug Newgard (Scimmia) - Friday, 18 November 2016, 15:18 GMT
"The problem may be a bug in the fuse package not recognizing correctly what is on the disk"

No, the "bug" is in not rebooting after a kernel upgrade.

Loading...