Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51832 - [chromium] please consider disabling media-router by default

Attached to Project: Arch Linux
Opened by Vasily Khoruzhick (anarsoul) - Monday, 14 November 2016, 20:43 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 29 January 2017, 17:15 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

Chromium lacks some code for built-in chromecast support to work properly. Thus if media router is activated (it is by default) chromium can't find chromecast device on the net, and at the same time chromecast extension is blocked because non-functional built-in support is active.

Upstream bug is closed as "won't fix"

Additional info:
* package version(s)
54.0.2840.100-1
* config and/or log files etc.

Debian bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833477
Upstream bug:
https://bugs.chromium.org/p/chromium/issues/detail?id=623290

Steps to reproduce:
Try to cast a tab to chromecast using chromium.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 29 January 2017, 17:15 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Flag is no longer in Chromium
Comment by Doug Newgard (Scimmia) - Tuesday, 15 November 2016, 00:22 GMT
Yes, please! Thank you, anarsoul, for taking the time to figure out why this didn't work!
Comment by Easy Rider (redbaron) - Friday, 02 December 2016, 18:47 GMT
Disabling the built-in chromecast support doesn't fix the problem.
Chromium will crash without any error message if you try to manage or add a new device using the old chromecast plugin.
Comment by Doug Newgard (Scimmia) - Friday, 02 December 2016, 23:36 GMT
The plugin works just fine for detected devices, though. Better than nothing.
Comment by Doug Newgard (Scimmia) - Friday, 27 January 2017, 15:28 GMT
This option seems to be gone in Chromium 56, I can't figure out how to disable the built-in chromecast support anymore :(
Comment by Doug Newgard (Scimmia) - Friday, 27 January 2017, 15:35 GMT
I found that you can now enable chrome://flags/#load-media-router-component-extension

This allows Chromium to download the binary media-router from Chrome, making built in casting work.

EDIT: MAY CRASH CHROMIUM!!!
Comment by Easy Rider (redbaron) - Sunday, 29 January 2017, 16:40 GMT
@Doug: Same here. Chromium will crash, and goes into a crash loop if I enable chrome://flags/#load-media-router-component-extension
Because of this crash loop I had to delete the ~./config/chromium folder. I observed that casting works correctly until I log in again into my Google account. Probably one of my extensions makes Chromium to go into this crash loop.
Try to use the casting function with a vanilla Chromium, without any extension and without a Google account. See what happens...
Comment by Doug Newgard (Scimmia) - Sunday, 29 January 2017, 17:14 GMT
I tried it with all extensions disabled, still crashes. Not willing to remove the account right now.

I've been able to get back in by removing ~/.config/chromium/Default/Extensions/pkedcjkdefgpdelpbcmbmeomcjbeemfm/ . It won't re-download until you disable and renable the extension on the flags page.

Since the original intent of this ticket is no longer valid, I'm going to close it. We can continue on the forums, maybe?

Loading...