Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51816 - [cjs] error while loading shared libraries: libreadline.so.6

Attached to Project: Community Packages
Opened by Mathias Merscher (madddi) - Monday, 14 November 2016, 10:37 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 14 November 2016, 17:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexandre Filgueira (faidoc)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
The readline 7 upgrade breaks cinnamon. Cinnamon is linked against libreadline 6 and fails to start after upgrading to the new version due to missing libraries.

$ ldd /usr/bin/cinnamon | grep readline
libreadline.so.6 => /usr/lib/libreadline.so.6

Additional info:
* cinnamon 3.2.1-4
* readline 7.0-1


Steps to reproduce:
* Install readline 7
* Start cinnamon
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 14 November 2016, 17:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  cjs 3.2.0-2
Comment by Doug Newgard (Scimmia) - Monday, 14 November 2016, 16:59 GMT
Looks like it was upgraded to 3.2 after the readline rebuilt, but was never then rebuilt for readline. The current version in Community works, but is older than the previous version so pacman ignores it.

Loading...