Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51791 - [mutter] unable to open session with Xorg after update to 3.22.2

Attached to Project: Arch Linux
Opened by Pierre Durand (Pierrre) - Friday, 11 November 2016, 12:24 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 16 November 2016, 17:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I updated my whole system:

[2016-11-11 11:23] [PACMAN] Running 'pacman --color auto -Sy'
[2016-11-11 11:23] [PACMAN] synchronizing package lists
[2016-11-11 11:23] [PACMAN] Running 'pacman --color auto -S -u'
[2016-11-11 11:23] [PACMAN] starting full system upgrade
[2016-11-11 11:23] [ALPM] transaction started
[2016-11-11 11:23] [ALPM] upgraded gpgme (1.6.0-3 -> 1.7.1-2)
[2016-11-11 11:23] [ALPM] upgraded appstream-glib (0.6.3-1 -> 0.6.5-1)
[2016-11-11 11:23] [ALPM] upgraded boost-libs (1.62.0-2 -> 1.62.0-3)
[2016-11-11 11:23] [ALPM] upgraded file-roller (3.22.1-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-calculator (3.22.1-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-disk-utility (3.22.0+3+gb7a9243-1 -> 3.22.1-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-online-accounts (3.22.1-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-session (3.22.1-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded mutter (3.22.1+41+ge8fc090-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-shell (3.22.1+2+g5a08886-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-shell-extensions (3.22.1-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-software (3.22.1-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded gnome-system-monitor (3.22.0+3+g8e6b08a-1 -> 3.22.2-1)
[2016-11-11 11:23] [ALPM] upgraded vte-common (0.46.0+5+g398a3f8-1 -> 0.46.1-1)
[2016-11-11 11:23] [ALPM] upgraded vte3 (0.46.0+5+g398a3f8-1 -> 0.46.1-1)
[2016-11-11 11:24] [ALPM] upgraded gnome-terminal (3.22.0+4+g87e36d3-1 -> 3.22.1-1)
[2016-11-11 11:24] [ALPM] upgraded linux (4.8.6-1 -> 4.8.7-1)
[2016-11-11 11:24] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2016-11-11 11:24] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio. Please wait...
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Starting build: 4.8.7-1-ARCH
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Image generation successful
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Starting build: 4.8.7-1-ARCH
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2016-11-11 11:24] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2016-11-11 11:24] [ALPM-SCRIPTLET] ==> Image generation successful
[2016-11-11 11:24] [ALPM] installed c-ares (1.12.0-1)
[2016-11-11 11:24] [ALPM] upgraded nodejs (7.0.0-1 -> 7.1.0-1)
[2016-11-11 11:24] [ALPM] upgraded oniguruma (6.1.1-1 -> 6.1.2-1)
[2016-11-11 11:24] [ALPM] upgraded python-docker-py (1.10.5-1 -> 1.10.6-1)
[2016-11-11 11:24] [ALPM] upgraded python-setuptools (1:28.7.1-1 -> 1:28.8.0-1)
[2016-11-11 11:24] [ALPM] upgraded python2-setuptools (1:28.7.1-1 -> 1:28.8.0-1)
[2016-11-11 11:24] [ALPM] upgraded shared-color-targets (0.1.6-1 -> 0.1.7-1)
[2016-11-11 11:24] [ALPM] upgraded xfsprogs (4.7.0-1 -> 4.8.0-1)
[2016-11-11 11:24] [ALPM] upgraded youtube-dl (2016.11.04-1 -> 2016.11.08.1-1)
[2016-11-11 11:24] [ALPM] transaction completed
[2016-11-11 11:24] [ALPM] running 'glib-compile-schemas.hook'...
[2016-11-11 11:24] [ALPM] running 'gtk-update-icon-cache.hook'...
[2016-11-11 11:24] [ALPM] running 'texinfo-install.hook'...
[2016-11-11 11:24] [ALPM] running 'update-desktop-database.hook'...

Then after a reboot, I can't open a session with Xorg.
It just displays the default gray background.

I still use Xorg instead of wayland because:
- synergy doesn't work
- redshift doesn't work
- VLC crashes the system

My computer: latest Dell XPS 15

I will try to rollback gnome a see if it fixes the issue.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 16 November 2016, 17:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.22.2+1
Comment by Pierre Durand (Pierrre) - Friday, 11 November 2016, 12:33 GMT
I rollbacked these packages, and now I can open a session with Xorg:
file-roller-3.22.1-1-x86_64.pkg.tar.xz
gnome-calculator-3.22.1-1-x86_64.pkg.tar.xz
gnome-disk-utility-3.22.0+3+gb7a9243-1-x86_64.pkg.tar.xz
gnome-online-accounts-3.22.1-1-x86_64.pkg.tar.xz
gnome-session-3.22.1-1-x86_64.pkg.tar.xz
gnome-shell-3.22.1+2+g5a08886-1-x86_64.pkg.tar.xz
gnome-shell-extensions-3.22.1-1-any.pkg.tar.xz
gnome-software-3.22.1-1-x86_64.pkg.tar.xz
gnome-system-monitor-3.22.0+3+g8e6b08a-1-x86_64.pkg.tar.xz
gnome-terminal-3.22.0+4+g87e36d3-1-x86_64.pkg.tar.xz
mutter-3.22.1+41+ge8fc090-1-x86_64.pkg.tar.xz
Comment by Jan de Groot (JGC) - Friday, 11 November 2016, 13:47 GMT
This bugreport is worthless without logs.
Comment by Pierre Durand (Pierrre) - Friday, 11 November 2016, 14:07 GMT
Here is a log from journalctl.
Do you need anything else ?
   bug.log (120.3 KiB)
Comment by Jan de Groot (JGC) - Friday, 11 November 2016, 14:27 GMT
Mutter has some libinput-related changes, you could try to revert only the mutter package.
Comment by Pierre Durand (Pierrre) - Friday, 11 November 2016, 14:31 GMT
After a rollback to mutter-3.22.1+41+ge8fc090-1, I can open a Gnome session with Xorg.
Comment by Alexander Pavel (SuperIce97) - Saturday, 12 November 2016, 19:44 GMT
I'm having this issue as well. I just woke up, turned my computer on, and gdm simply failed to start. After over an hour I stumbled upon this and after reverting mutter to 3.22.1+41 the issue is gone. My computer is a laptop with an i7-2630QM and an nVidia 570M graphics card (and I can only use Xorg as a result). I have another laptop with a Celeron 3205u and Intel graphics that can run both the Wayland and Xorg sessions fine with the latest mutter (3.22.2-1). I have temporarily added mutter as an ignore package in pacman on the laptop having issues until this gets fixed.
Comment by Jan Alexander Steffens (heftig) - Saturday, 12 November 2016, 20:00 GMT
Does this build work fine? It reverts commit 374bba2d4e75a3f801f225565ed2c31f5ec2ceec, part of https://bugzilla.gnome.org/show_bug.cgi?id=771744

https://pkgbuild.com/~heftig/mutter-3.22.2-1-x86_64.pkg.tar.xz
Comment by Alexander Pavel (SuperIce97) - Saturday, 12 November 2016, 20:46 GMT
Yes, that build works fine.
Comment by Jan Alexander Steffens (heftig) - Saturday, 12 November 2016, 21:15 GMT
Is it right that your touchpad does not support two-finger scrolling?
Comment by Alexander Pavel (SuperIce97) - Saturday, 12 November 2016, 21:32 GMT
I used to be able to do two finger scrolling with this touchpad, but it was jumpy so I used right hand scrolling instead. Testing it now, there is no way I can enable two-finger scrolling and even single finger scrolling is acting weird. I can scroll on my touchpad, but if I touch the top or bottom of the right-hand side it automatically scrolls. I don't know when this happened as I basically never use the touchpad on this old laptop (it weighs 8 pounds so it's really more like a somewhat portable desktop).
Comment by Pierre Durand (Pierrre) - Saturday, 12 November 2016, 21:38 GMT
@heftig yes it's working
Comment by Michael Heyns (beanaroo) - Sunday, 13 November 2016, 04:14 GMT
I have a Dell XPS 15. After upgrading to mutter-3.22.1+49+g462d504-1, I had the same/similar issue. I have GDM set to Xorg and it was segfaulting. (Rolled back to mutter-3.22.1+41+ge8fc090-1)

Today I updated to mutter-3.22.2-1 and unfortunately no change.

Heftig's pkg does indeed work (thank you). Do we need to inform upstream?
Comment by Jan Alexander Steffens (heftig) - Sunday, 13 November 2016, 04:43 GMT
Yeah; Maybe that bug should be reopened. I guess that trying to set properties to invalid values provokes BadValue X errors that aren't caught correctly.
Comment by Gian Andrea (gkun) - Sunday, 13 November 2016, 19:57 GMT
I have a Nvidia GeForce GT420 and the same bug. Wayland is not an option so I am forced to keep mutter downgraded. I hope this can be solved soon...
Comment by Jan Alexander Steffens (heftig) - Tuesday, 15 November 2016, 12:00 GMT
Can you try https://pkgbuild.com/~heftig/mutter-3.22.2-1-x86_64.pkg.tar.xz again and tell me if it still works?

It now contains a new fix from upstream.
Comment by Ulrik Boll Djurtoft (Ullebe1) - Tuesday, 15 November 2016, 16:20 GMT
@heftig The latest package you have linked fixes it for me.
Comment by Gian Andrea (gkun) - Tuesday, 15 November 2016, 21:51 GMT
@heftig tried it too, it works perfectly. :-)

Loading...