Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51784 - [paxd] problems with plasmashell and spectacle

Attached to Project: Community Packages
Opened by Fabian Franz (fabianfrz) - Thursday, 10 November 2016, 20:01 GMT
Last edited by Daniel Micay (thestinger) - Monday, 12 December 2016, 05:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Daniel Micay (thestinger)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
The kernel in linux-grsec has some problems with the plasma desktop.
I think there are some exceptions in the default paxd.conf missing.

When you try to leave the plasma session, nothing happens (the GUI where the logout / power off / reboot selection should be shown, does not appear). Printing the screen does not work as well because spectacle cannot start.

However i can power off my system by entering poweroff on the desktop.

Additional info:
* package version(s)
** linux-grsec 1:4.7.10.r201611011946-1
** plasmashell 5.8.3
** spectacle 16.08.2


Steps to reproduce:
break the leave screen: try to leave the session while using the linux-grsec kernel
spectacle: just push the print key and nothing happens
This task depends upon

Closed by  Daniel Micay (thestinger)
Monday, 12 December 2016, 05:31 GMT
Reason for closing:  Upstream
Additional comments about closing:  These are going to be tracked upstream.
Comment by Joe Gabinsky (SpuriousStar) - Thursday, 10 November 2016, 22:46 GMT
You should report it as paxd bug/feature rather than linux-grsec. Or to the upstream https://github.com/thestinger/paxd . However as the maintainer said few times before, user is expected to make most exceptions himself. There is already bugreport for spectacle https://bugs.archlinux.org/task/49462 .
for fix spectacle add in /etc/paxd.conf:

em /usr/bin/spectacle

for fix logout add:

em /usr/lib/ksmserver-logout-greeter

Next time check journalctl or ksytemlog for grsec errors which give you information about exceptions to add.

Loading...