Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51613 - [xorg-server] Cannot build in a clean chroot

Attached to Project: Arch Linux
Opened by Giancarlo Razzolini (grazzolini) - Monday, 31 October 2016, 15:08 GMT
Last edited by Laurent Carlier (lordheavy) - Friday, 13 January 2017, 13:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I tried to build the xorg-server in a clean chroot using extra-x86_64-build and the build process fails, because of libudev. I am rebuilding it with debugging symbols to track down a segmentation fault that has been hunting me these past couple of weeks. I attached a log of the relevant output.

Additional info:
* xorg-server-1.18.4-1

Steps to reproduce:
Run extra-x86_64-build with xorg-server PKGBUILD.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Friday, 13 January 2017, 13:20 GMT
Reason for closing:  Fixed
Comment by Celti Burroughs (Celti) - Monday, 31 October 2016, 15:16 GMT
Needs systemd added to makedepends. libsystemd does not include the libudev headers that this requires to build, they're in the main systemd package.

Loading...