Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51598 - [cups-filters] Update to 1.11.5 breaks printing

Attached to Project: Arch Linux
Opened by Jörg Volbers (pil) - Monday, 31 October 2016, 09:08 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 02 November 2016, 21:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:

Printing with CUPS did not work anymore. Got the error message "filter failed" (on the cups web backend). Reverting to cups-filters to 1.11.4 made everything work fine again.

I have no time and no energy to track the real cause, but thought it should be known.


Additional info:
* package version(s)

cups-filters 1.11.5
cups-filters 1.11.4


Steps to reproduce:

- If printing does not work anymore, downgrade cups-filters.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 02 November 2016, 21:15 GMT
Reason for closing:  Fixed
Comment by Ganesh Ajjanagadde (gajjanag) - Monday, 31 October 2016, 13:38 GMT
Affects me as well; attached a sample job from /var/log/cups/error_log.
Comment by Georg Pichler (GeorgP) - Monday, 31 October 2016, 13:56 GMT
Here is part of my error_log with "LogLevel debug".
Comment by Andreas (carador) - Monday, 31 October 2016, 14:42 GMT
True.

In my error_log there is a call to popplers pstops (because I use a Konica Minolta Workgroup Printer), which fails.

Best
Andreas
Comment by Gaëtan Harter (cladmi) - Monday, 31 October 2016, 14:58 GMT
Same issue with 1.11.5, downgrading to 1.11.4 also fixed the issue.
Comment by Richard (archer666) - Monday, 31 October 2016, 15:22 GMT
same happened here with a fresh Arch install (2016-10-1).
after being pointed to this bug report and downgrading cups-filters to 1.11.4 all is well.
https://bbs.archlinux.org/viewtopic.php?id=218970
Comment by Andreas (carador) - Monday, 31 October 2016, 16:15 GMT
Found some suspicious log entry

D [31/Oct/2016:15:49:12 +0100] [Job 3679] Usage: pdftops job user title copies options [file]

with cups-filters 1.11.5 which closely resembles the output of

[user@host /]# /usr/lib/cups/filter/pdftops job user title copies [options file extra]
Usage: ./pdftops job user title copies options [file]
Comment by eaut (eaut) - Monday, 31 October 2016, 20:26 GMT
Same here! reverting to cups-filters to 1.11.4 made everything work fine again.
Comment by Hervé (herve) - Tuesday, 01 November 2016, 11:26 GMT
Same problem with a Brother printer and same solution reverting to cups-filters to 1.11.4.

In both cases it calls the same /usr/lib/cups/filter/pdftopdf and /usr/lib/cups/filter/pdftops filters.
Comment by AK (Andreaskem) - Tuesday, 01 November 2016, 11:54 GMT
Comment by Andreas (carador) - Tuesday, 01 November 2016, 13:58 GMT
Agree.

./configure --with-pdftops-path=/usr/bin/pdftops

is a possible fix/workaround until 1.11.6 is released.

Tested myself with modified PKGBUILD for extra/cups-filters and works flawlessly.

Comment by Manuel (schnecki) - Tuesday, 01 November 2016, 19:02 GMT
Same Problem here. Reverted from cups-filters-1.11.5-1 to cups-filters-1.11.4.-1 and it works again.
Comment by Sachin Garg (randompie) - Tuesday, 01 November 2016, 19:38 GMT
Same problem with a Brother HL-3170CDW. "downgrading package cups-filters (1.11.5-1 => 1.11.4-1)" solves the issue.
Comment by Ganesh Ajjanagadde (gajjanag) - Wednesday, 02 November 2016, 14:13 GMT
Seems solved with 1.11.6-1, which now has been released.
I guess this should be closed.

Loading...