Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51584 - [amule] build against wxgtk 3 instead of 2.8

Attached to Project: Arch Linux
Opened by Sebastiaan Lokhorst (lonaowna) - Sunday, 30 October 2016, 13:18 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 22 January 2017, 23:55 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

As mentioned in the amule 2.3.2 release notes[1], amule should work fine with wxgtk 3.0. Please depend on that instead of 2.8.

Also, isn't it better to use the release from GitHub?[2]

[1] https://github.com/amule-project/amule/releases/tag/2.3.2
[2] https://github.com/amule-project/amule/archive/2.3.2.tar.gz
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 22 January 2017, 23:55 GMT
Reason for closing:  Implemented
Comment by Pablo Lezaeta (Jristz) - Wednesday, 07 December 2016, 06:45 GMT
since amule is not compatible with wxwindows 3.1 that was released I don't think is a good idea unles we also ship the "compat" patch.
Comment by Antonio Rojas (arojas) - Wednesday, 07 December 2016, 09:01 GMT
even with 3.0, amule segfaults soon after starting. So no, it's not ready yet regardless what the release notes say.
Comment by Sebastiaan Lokhorst (lonaowna) - Wednesday, 07 December 2016, 11:16 GMT
Strange, it seems to work fine here (with 3.0)..

I made the following changes to the PKGBUILD: https://gist.github.com/slokhorst/a76f83fe1613703de908d1846f57912f

Loading...