Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51511 - [chromium] NaCL is not available in Chromium x86_64 build

Attached to Project: Arch Linux
Opened by Łukasz (dolohow) - Sunday, 23 October 2016, 17:28 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 07 March 2019, 20:12 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:


Additional info:
* 54.0.2840.71-1


Steps to reproduce:
1. Go to about:plugins
2. NaCL plugin is not listed.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 07 March 2019, 20:12 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Please use Google Chrome for stuff requiring NaCL.
Comment by Thomas Bohn (tehabe) - Sunday, 23 October 2016, 18:54 GMT Comment by Łukasz (dolohow) - Sunday, 23 October 2016, 18:58 GMT
And the reason is? I understand it was disabled in i686 build, but why in x86_64?
Comment by Gustavo Alvarez (sl1pkn07) - Sunday, 23 October 2016, 19:17 GMT
because need use/build with internal ICU instead system ICU (in the chromium-dev channel at least)
Comment by Łukasz (dolohow) - Sunday, 23 October 2016, 19:21 GMT
Is there anything that could be done to make chromium bundled NaCL?
Comment by Evangelos Foutras (foutrelis) - Tuesday, 29 November 2016, 07:55 GMT
I made the decision to drop NaCL support because the pnacl toolchain provided by Google required ncurses 5.x to run (we have ncurses 6.x in Arch).

While it's probable there are ways to build NaCL in Chromium, I don't think the added benefit is worth the maintenance overhead.

My assumption being that NaCL is used very infrequently and/or by a very limited number of people, it makes sense to have those people use Google Chrome for stuff requiring NaCL.
Comment by Yu, Li Yu (afg) - Thursday, 07 March 2019, 19:44 GMT
  • Field changed: Percent Complete (100% → 0%)
It is no longer the case that the pnacl toolchain requires ncurses 5.x to run, could we re-consider enabling nacl?
Currently enabling NaCl requires internal icu though. (https://crbug.com/678661)
Comment by Evangelos Foutras (foutrelis) - Thursday, 07 March 2019, 20:12 GMT

Loading...