Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51506 - [linux] Boot freeze after "loading initial ramdisk" with 4.8.1+

Attached to Project: Arch Linux
Opened by stream9 (stream9) - Sunday, 23 October 2016, 05:29 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 08 December 2017, 13:38 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
Boot freeze after "Loading initial ramdisk" line.

System can't boot since I upgrade kernel from 4.7.6 to 4.8.2.
4.8.3 also freeze at same point. Curiously, 4.8 boot fine.

- PC is 10+ year old DELL Latitude V740.
- It is known to have problematic ACPI BIOS.
- Kernel parameter acpi=off make no difference about freezing
- Kernel parameter debug doesn't produce any output.

Additional info:

For reference I attach boot log (journalctl -b) on 4.8.

Steps to reproduce:
1. power on
2. select kernel in grub
3. freeze after "Loading initial ramdisk" line was displayed.
   boot.log (62.6 KiB)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 08 December 2017, 13:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed with the latest kernel releases
Comment by stream9 (stream9) - Sunday, 23 October 2016, 05:36 GMT
I should start summary with [linux]. I can't find out how to edit. Sorry about that.
Comment by Luca Steinke (phre4k) - Sunday, 23 October 2016, 09:50 GMT
I can confirm this for the following kernel versions:
linux-4.8.4-1-x86_64
linux-4.8.3-1-x86_64
linux-4.8.2-1-x86_64
linux-4.8.1-1-x86_64

It works with linux-4.8-1-x86_64.

Boot log for the first version where this occurs (4.8.1-1-x86_64) attached.

I think a warning on the home page to not upgrade beyond 4.8-1 is warranted.
   boot.log (116 KiB)
Comment by Matthias Mayer (pAiN) - Sunday, 23 October 2016, 11:24 GMT
Same issue on two i686 machines (Thinkpad X31 and T42).
Comment by fzap (fzap) - Monday, 24 October 2016, 17:10 GMT
can confirm this issue with old hardware (2006) "AMD Athlon 64 X2 5400+, Black Edition". I've switched to LTS-kernel "4.4.27-1-lts" and the machine boots normally.
Comment by Sabaku no Kisuke (snkisuke) - Tuesday, 25 October 2016, 05:11 GMT
maybe the same bug as  FS#51455 .
You can try with "ignore_loglevel earlyprintk=vga,keep" on kernel parametrers instead of "debug" on systems with BIOS, and try "ignore_loglevel earlyprintk=efi,vga,keep" on EFI to obtain some output from kernel at early boot.
Comment by liara (liara) - Tuesday, 25 October 2016, 06:17 GMT
^^ tried that, but still no logs for me.
Comment by Jeff Pohlmeyer (yetanothergeek) - Wednesday, 26 October 2016, 05:35 GMT
Did a git bisect from this repo:
git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git


Testing on an old Dell Inspiron 1100 laptop, ended up with this:

4927f9e7a267883ca0741d3fefa063faf43a9344 is the first bad commit
commit 4927f9e7a267883ca0741d3fefa063faf43a9344
Author: Prarit Bhargava <prarit@redhat.com>
Date: Mon Oct 3 13:07:12 2016 -0400
arch/x86: Handle non enumerated CPU after physical hotplug
commit 2a51fe083eba7f99cbda72f5ef90cdf2f4df882c upstream.


Did a quick google search and it looks like this might be relevant:

http://www.gossamer-threads.com/lists/linux/kernel/2551992

[Edit]
See also:
https://github.com/torvalds/linux/commit/ff8560512b8d4b7ca3ef4fd69166634ac30b2525
Comment by Jeff Pohlmeyer (yetanothergeek) - Sunday, 30 October 2016, 09:52 GMT
Built kernel 4.8.5 stable from source and the problem appears to be fixed, at least for me.
Comment by stream9 (stream9) - Thursday, 03 November 2016, 03:29 GMT
Upgrade to 4.8.6 and it boot fine. I think 4.8.5 is ok too, but I haven't tried.
Comment by Jeff Pohlmeyer (yetanothergeek) - Thursday, 03 November 2016, 04:26 GMT
4.8.6 is good for me as well.
Comment by Luca Steinke (phre4k) - Thursday, 03 November 2016, 17:59 GMT
nope, neither 4.8.5 nor 4.8.6 work for me. Downgrading to 4.7.6 solves the issue, as did it last time.
Comment by Henrique Dias (mrhdias) - Saturday, 05 November 2016, 18:15 GMT
Any linux-4.8 version does not work!

Toshiba satellite c8500-125
AMD Dual-Core A4-4300M APU com AMD Radeon™ HD 7420G + 7610M Dual Graphics
Comment by f (bakgwailo) - Wednesday, 07 June 2017, 03:55 GMT
I get the same thing on the latest linux kernel (4.11.3, happened rather recently), but linux-lts is booting fine for me (4.9.30). Freezes at the 'Loading initial ramdisk' line, can't get any debugging output from it. It is on an FX-8350. My more recent i7 system is fine.
Comment by f (bakgwailo) - Thursday, 30 November 2017, 18:57 GMT
Just wanted to add both the latest kernel (4.13.12-1) and the LTS kernel are working fine for me. Seemed like a kernel issue fixed in the 4.11 or 4.12 series.
Comment by loqs (loqs) - Thursday, 30 November 2017, 23:19 GMT
@bakgwailo happy to read the issue is resolved for you.
@stream9 is the issue resolved for you as well?
Comment by stream9 (stream9) - Friday, 08 December 2017, 11:52 GMT
@loqs. Yes, the issue has resolved long time ago.
Did I suppose to close or change status?

Loading...