Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51487 - [ardour] ardour.desktop information not updated to match new version rendering it non-functional.

Attached to Project: Arch Linux
Opened by Llewelyn Trahaearn (llewelyn) - Saturday, 22 October 2016, 02:59 GMT
Last edited by Ray Rashif (schivmeister) - Friday, 17 February 2017, 14:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: The information in the source .desktop file was not updated for Ardour 5.4, leaving it pointing to locations and files that do not exist (https://git.archlinux.org/svntogit/packages.git/tree/trunk/ardour.desktop?h=packages/ardour). Under GNOME this results in the icon for the app not being displayed; however, in other environments it could result in a non-functional icon being displayed. Utilizing gendesk to generate the desktop file instead of relying on a static source would probably remedy this problem indefinitely.


Additional info: ardour 5.4-1


Steps to reproduce: Install/Update the ardour 5.4-1 package.
This task depends upon

Closed by  Ray Rashif (schivmeister)
Friday, 17 February 2017, 14:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  testing/5.6-1
Comment by Llewelyn Trahaearn (llewelyn) - Tuesday, 08 November 2016, 05:31 GMT
As there was no change to the source ardour.desktop file this bug persists in 5.4-2

I took a moment to implement the suggested change, using gendesk to generate the .desktop file instead of sourcing it. The file generated is nearly identical to the existing ardour.desktop save that it works against ardour 5. The changes to the PKGBUILD are minimal and mostly constrained to prepare().

The updated PKGBUILD can be examined here: https://gist.github.com/WoefulDerelict/b2acd064e3f231f0cb10b1fe99120b73
Comment by Doug Newgard (Scimmia) - Saturday, 26 November 2016, 14:20 GMT
gendesk is no better than a .desktop file. Either would need changed. Really, gendesk is pretty useless.
Comment by Johannes Maibaum (jmx) - Monday, 28 November 2016, 12:57 GMT
You could easily "parametrize" the call to gendesk so that it doesn't have to be altered for each new major version (simply concatenate a string using the information from $pkgname and $pkgver).

I have attached a modified PKGBUILD based on Lleweln's Gist with a "parametrized" call to gendesk.

I'd really love to see Ardour 5.4 in community instead of community-testing in the near future!
   PKGBUILD (1.9 KiB)
Comment by Ray Rashif (schivmeister) - Monday, 28 November 2016, 17:21 GMT
Hi all, sorry for keeping this idle, and for keeping ardour in testing. I had left it there because I rarely receive any feedback, and the update was several versions' jump. I will see to it that this gets incorporated and I'll move it out of testing, since there have been no further reports on anything else.
Comment by Llewelyn Trahaearn (llewelyn) - Tuesday, 29 November 2016, 17:39 GMT
I suspect that most users are only driven to provide feedback during testing if they find something behaving unexpectedly. During my own exploration the only noteworthy issue I noticed with this new version was a missing icon in environments utilizing the freedesktop.org .desktop file as that hadn't been updated for the new version.

There are certainly a number of ways to solve this particular problem and sacrificing simplicity some could even be robust. Dynamically generating or modifying the content using standard PKGBUILD variables like $pkgver as jmx suggested is a simple favourite used in many PKGBUILDs; however, it is easily defeated by changes in resource locations. This can be seen in the most recent update from Ardour 4 to 5. The icon was moved from /usr/share/ardour4/icons/ardour_icon_256px.png to /usr/share/ardour5/resources/Ardour-icon_256px.png. So long as the resource names remain predicable it would be possible to locate and dynamically insert/update this information. This could of course just as easily be done with sed and a source stub or even echo as it could with gendesk. As one was just mocking up an alternative in the most easy to read and understand fashion I'm not expressly advocating it as the solution. I'll leave the deployment details to the maintainer as continued upkeep remains their responsibility so whichever tools they are familiar with are probably best.
Comment by Johannes Maibaum (jmx) - Saturday, 17 December 2016, 17:52 GMT
Hi,

I have corrected one small issue in my previous "parametrized" PKGBUILD that I posted 3 weeks ago.

By the way, I have just used this PKGBUILD to build the by now released Ardour 5.5 and I edited music with this build the whole afternoon without coming across any issues. I think it's fairly safe to finally bump the Ardour version in community!


Best,
jmx
   PKGBUILD (1.9 KiB)
Comment by Ray Rashif (schivmeister) - Friday, 17 February 2017, 14:22 GMT
Hi guys, thanks a lot for your input here, but I have decided to forego the scripting as it is a bit overkill for the task that needs accomplished. I apologize again for delaying an update along with this.

Loading...