Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51442 - [libx11] 1.6.4-1 breaks diacritics with LibreOffice

Attached to Project: Arch Linux
Opened by Nicky726 (Nicky726) - Wednesday, 19 October 2016, 13:30 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 18 March 2017, 10:00 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Upgrading libx11 to version 1.6.4-1 breaks diacritics with LibreOffice:
- using a deadkey to write diacritics is no longer possible (only the character without diacritics appears),
- opening/saving files with filenames or path containing characters with diacritics is not possible (GUI error file does not exist)

Additional info:
* package version(s)
libx11: 1.6.4-1
libreoffice-still: 5.1.5-3
libreoffice-fresh: 5.2.2-2

* config and/or log files etc.
When running libreoffice from console, following error messages appear:
I18N: X Window System doesn't support locale "LC_CTYPE=cs_CZ.utf8;LC_NUMERIC=cs_CZ.UTF-8;LC_TIME=cs_CZ.UTF-8;LC_COLLATE=cs_CZ.UTF-8;LC_MONETARY=cs_CZ.UTF-8;LC_MESSAGES=cs_CZ.utf8;LC_PAPER=cs_CZ.utf8;LC_NAME=cs_CZ.utf8;LC_ADDRESS=cs_CZ.utf8;LC_TELEPHONE=cs_CZ.utf8;LC_MEASUREMENT=cs_CZ.UTF-8;LC_IDENTIFICATION=cs_CZ.utf8"
I18N: Operating system doesn't support locale "en_US"
X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 42 (X_SetInputFocus)
Resource id: 0x880002f

Steps to reproduce:
Check that you have libx11 1.6.4-1 installed, open LibreOffice and try to type diacritical character using a deadkey (tested with Czech characters). Observe that only character without diacritics is written.

Try to open a LibreOffice document which has a diacrtics character in a) file name b) path, observe that no file is opened and error messing stating file does not exist is displayed.

Now downgrade libx11 to 1.6.3-1, repeat the above and observe no problems.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 18 March 2017, 10:00 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Wednesday, 19 October 2016, 13:45 GMT
Related to https://bugs.freedesktop.org/show_bug.cgi?id=81875

Last comment has a patch that should fix this issue.

Comment by Nicky726 (Nicky726) - Thursday, 20 October 2016, 10:51 GMT
I patched libx11 with a mentioned patch, however the results are mixed:
- diacritical characters using a deadkey can now be written in LibreOffice,
- files with diacritics in name/path still cannot be open in LibreOffice.

Also, some of the error messages in console no longer appear:
$ pwd
/home/nik/Dokumenty/Škola/studium/17.semestr/AIQ-test/aiq-src
$ libreoffice AIXI-Descriptive\ Statistics.ods
X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 42 (X_SetInputFocus)
Resource id: 0x820002f

However, I noticed that there is X Error: BadMatch even with libx11 downgraded to 1.6.3-1, so this error message may not be related.
Comment by Andreas Radke (AndyRTR) - Thursday, 20 October 2016, 14:37 GMT
You should report that back to the upstream report.
Comment by Nicky726 (Nicky726) - Thursday, 20 October 2016, 20:12 GMT
Sure, done.
Comment by Andreas Radke (AndyRTR) - Saturday, 18 February 2017, 20:43 GMT
https://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=23d9623c661694aba8cf1e8f277dffa7a86cf065

Does that one fix your bug? (there's en_DK.UTF-8 also mentioned in the upstream report, maybe that one should be removed too).
Comment by Nicky726 (Nicky726) - Saturday, 18 February 2017, 21:29 GMT
The patch you link is the same as I have tested, only condensed in writing. As for en_DK.UTF-8, I would not say so, since there is no duplicity, as was the case with cs_CZ.UTF-8.
Comment by Nicky726 (Nicky726) - Thursday, 16 March 2017, 09:19 GMT
With libx11 1.6.5-1 both the issues are fixed.

Loading...