Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51432 - [gtk3] symbol lookup error: /usr/lib/libgtk-3.so.0: undefined symbol: g_log_structured

Attached to Project: Arch Linux
Opened by Jon Lane (jlane) - Tuesday, 18 October 2016, 19:28 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 18 October 2016, 20:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Attempting to launch any Gtk3 application with gtk-3.22 installed as libgtk-3.so.0 throws the following error:

symbol lookup error: /usr/lib/libgtk-3.so.0: undefined symbol: g_log_structured

This is consistent across multiple installations under multiple environments. In all cases downgrading to the prior version of the gtk3 package fixed the issue. This is flagged as critical since it breaks every single gtk3 application that doesn't bundle their own like Firefox.

This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 18 October 2016, 20:05 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial updates are not supported
Comment by Antonio Rojas (arojas) - Tuesday, 18 October 2016, 19:54 GMT
which version of glib2?
Comment by Jon Lane (jlane) - Tuesday, 18 October 2016, 19:59 GMT
2.48.2-1

Loading...