Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51408 - [firefox] No printers since GTK 3.22

Attached to Project: Arch Linux
Opened by Xorg (Xorg) - Sunday, 16 October 2016, 19:06 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 16 October 2016, 19:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Since update to GTK 3.22, Firefox doesn't propose to print PDF "on paper". Only "Print in a file" is available.

Install package gtk3-print-backends solve this issue. Maybe it needs to be added in optdepends?


Additional info:
* firefox 49.0.1
* gtk3-3.22.1
* Issue on forum + solution: https://bbs.archlinux.org/viewtopic.php?pid=1658177#p1658177


Steps to reproduce:
Open a PDF in Firefox, and try to print a PDF.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 16 October 2016, 19:13 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Already an optional dep of gtk3. Pay attention to what pacman tells you on update.

Loading...