Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#51406 - [kdevelop] dependency satisfied but unable to run with old version of kdevplatform

Attached to Project: Arch Linux
Opened by msrd0 (msrd0) - Sunday, 16 October 2016, 17:00 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 16 October 2016, 17:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


I just found out that KDevelop 5 was released and wanted to install it. I entered `pacman -Sy kdevelop` and
tried to run `kdevelop` on the command line. This resulted in the following error:

kdevelop: symbol lookup error: kdevelop: undefined symbol: _ZN8KDevelop17SessionController21availableSessionInfosEv

After some investigation why this symbol was missing (in fact I thought about compiling the package from source
and looked into the official PKGBULD) I found out that another package called kdevplatform needed an update
for kdevelop to run (updating that package as well solved the problem).

Can you please add a version requirement to the dependencies of the kdevelop package so kdevplatform gets updated
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 16 October 2016, 17:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial updates are not supported