Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51402 - [gtk3] 3.22.1+8+ge11df6c-2 : Broken display after waking from suspend

Attached to Project: Arch Linux
Opened by jib (jib2) - Sunday, 16 October 2016, 08:11 GMT
Last edited by Jan de Groot (JGC) - Friday, 19 May 2017, 23:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After waking from sleep, windows don't open normally in gtk3 applications, f.i.:
- firefox opens in a tiny window and mouse is unresponsive on some icons
- nautilus opens in a smaller window than previously
- nemo doesn't show at all (although it's running)
...

Additional info:
* package version(s) gtk3 3.22.1+8+ge11df6c-2

Steps to reproduce:
Let the computer go to sleep or suspend, then wake and open firefox (or any gtk3 app).
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 19 May 2017, 23:02 GMT
Reason for closing:  No response
Comment by jib (jib2) - Sunday, 16 October 2016, 15:58 GMT
Downgrading to 3.22.1-1 didn't solve the problem.
Comment by Daniel M. Capella (polyzen) - Sunday, 16 October 2016, 17:31 GMT
Related to  FS#51399 ?
Comment by Jan de Groot (JGC) - Monday, 17 October 2016, 08:59 GMT
Looks like display scaling issues with HiDPI displays. Some questions:
- which screen/resolution
- wayland or xorg
- do you switch screens between suspend/resume
Comment by jib (jib2) - Monday, 17 October 2016, 11:18 GMT
Screen res. 1920x1080
xorg
no screnn switching.

Since I downgraded to 3.20.9-1, the problem didn't occur.
Comment by Jan de Groot (JGC) - Tuesday, 25 April 2017, 08:13 GMT
  • Field changed: Status (Assigned → Waiting on Response)
Is this still an issue with current gtk3 package?

Loading...