Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#51366 - [gvim] Significantly slower at scrolling updating 8.0005 to 8.0013

Attached to Project: Arch Linux
Opened by Mathias Stearn (RedBeard0531) - Thursday, 13 October 2016, 18:28 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 07 January 2018, 06:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned   Reopened
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No



I noticed that gvim was scrolling horrendously slowly. Downgrading to 8.005 solved the problem. I confirmed that it reappeared when upgrading back to 8.0013. Console vim does not appear to be affected. I also tried passing --noplugin to gvim, but it didn't seem to help.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:

Open a file with many hundred lines in gvim and quickly scroll up and down using the mouse. Downgrade to 8.0005 and try again.
This task depends upon

Comment by Mathias Stearn (RedBeard0531) - Thursday, 13 October 2016, 18:39 GMT
I noticed this commit and rebuilt with gtk2 and the problem is gone even on 8.0013. I think the issue is that vim's gtk3 gui is significantly slower than gtk2.
Comment by Anatol Pomozov (anatolik) - Sunday, 16 October 2016, 03:36 GMT
Would you mind to file a bug to the upstream project?
Comment by Mathias Stearn (RedBeard0531) - Wednesday, 26 October 2016, 17:20 GMT

Until it is fixed, is it possible to revert the PKGBUILD to using gtk2? I'm building my own gvim for now because of this, but I'm sure other people are affected by this without knowing how to solve it. I verified on a coworker's box that it isn't just a quirk of my machine.
Comment by Anatol Pomozov (anatolik) - Monday, 31 October 2016, 17:12 GMT
vim has been reverted to gtk2. Please track the upstream issue and once it is fixed we can try to enable gtk3 again.
Comment by Tim Ruffing (realorrandom) - Thursday, 30 November 2017, 16:15 GMT
  • Field changed: Percent Complete (100% → 0%)
The current revision uses gtk3 again even though the upstream issue has not been resolved.