Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51365 - [mkvtoolnix-gui] segfault on "add files"

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Thursday, 13 October 2016, 17:22 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 30 October 2016, 18:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The application crash on "add files"


Additional info:
* package version(s)

latest

* config and/or log files etc.
> mkvtoolnix-gui

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:151:54: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:173:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:178:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:182:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:187:58: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:195:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:200:58: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:211:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:218:58: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:221:75: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1026:69: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1040:71: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1049:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1055:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1066:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1069:58: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1076:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1079:58: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1302:71: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1309:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1313:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1434:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1438:58: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1441:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1840:9: Not using units is deprecated. Assuming 'px'.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:1840:9: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2595:53: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2625:51: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2628:53: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2633:53: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2633:87: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2878:8: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:2878:17: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3347:71: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3354:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3357:74: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3365:52: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3437:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3444:67: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3448:54: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3459:54: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3571:8: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3571:20: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3591:54: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3602:8: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3602:22: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3605:8: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3605:28: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3608:8: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3608:22: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3625:12: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3625:12: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3631:14: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3631:14: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3637:16: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3637:16: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3642:14: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3642:14: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3709:12: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3711:16: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3711:16: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3757:12: not a number

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3757:12: Expected a string.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3760:66: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3767:66: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3897:72: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3904:56: Using one color stop with linear-gradient() is deprecated.

(mkvtoolnix-gui:18771): Gtk-WARNING **: Theme parsing error: gtk.css:3907:73: Using one color stop with linear-gradient() is deprecated.
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile

(mkvtoolnix-gui:18771): Gdk-WARNING **: gdkwindow-x11.c:5554 drawable is not a native X11 window
zsh: segmentation fault (core dumped) mkvtoolnix-gui


Steps to reproduce:
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 30 October 2016, 18:03 GMT
Reason for closing:  Upstream
Comment by Maxime Gauduin (Alucryd) - Thursday, 20 October 2016, 09:55 GMT
Can't reproduce here. Does 9.5.0 fix this? Also, you're obviously using a problematic GTK theme, can you try with the default one, Adwaita ?
Comment by Antonio Rojas (arojas) - Thursday, 20 October 2016, 10:18 GMT
Pretty sure this is  FS#50013  again
Comment by Maxime Gauduin (Alucryd) - Sunday, 30 October 2016, 18:03 GMT
Looks like it indeed, thx Antonio. Closing this as well, please use one of the workarounds mentioned in  FS#50013  until this is fixed.

Loading...