Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51308 - [qt5-base] should not conflict with qtchooser

Attached to Project: Arch Linux
Opened by Shawn Rutledge (ecloud) - Monday, 10 October 2016, 12:35 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 11 October 2016, 06:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Upgrading to 5.7.0-3 forced me to uninstall qtchooser, so I thought maybe that's because it's to be included in the qt5-base package; but it's not. As a Qt developer I keep various versions of Qt around, so I use qtchooser.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 11 October 2016, 06:07 GMT
Reason for closing:  Not a bug
Comment by Shawn Rutledge (ecloud) - Monday, 10 October 2016, 12:36 GMT
Well actually qtchooser is just gone. Why?!?
Comment by Antonio Rojas (arojas) - Tuesday, 11 October 2016, 06:06 GMT
qt5-base provides files that were previously shipped in qtchooser, that is, by definition, a conflict. We removed qtchooser because giving users the option to change the behavior of system-wide commands is calling for trouble and makes debugging issues harder. You can still install it in /usr/local if you really need it, but it's not supported anymore.

Loading...