Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#51284 - [bluez] Version 5.42-1 prevents the computer from receiving files over bluetooth

Attached to Project: Arch Linux
Opened by Francisco Cribari (cribari) - Saturday, 08 October 2016, 01:49 GMT
Last edited by Jan de Groot (JGC) - Monday, 31 October 2016, 12:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


Description: After upgrading bluez, bluez-libs and bluez-utils from version 5.41-2 to version 5.42-1 I am no longer able to send files from my Android devices (cell phone and tablet) to my notebook (Dell XPS 13, model 9343, with Intel wifi+bluetooth card). (The Android devices are marked as "Trusted".) I am able to send files from the computer to the Android devices, but not the other way around.

Additional info:
* package version(s)

bluez, bluez-libs and bluez-utils to version 5.42-1

* config and/or log files etc.

Logs available at

See also

Note: I noticed that my last successful file transfer from my Android devices to my notebook was on September 26, 2016. I then noticed that on that day Bluez was updated:

[2016-09-26 13:11] [ALPM] upgraded bluez-utils (5.41-2 -> 5.42-1)
[2016-09-26 13:11] [ALPM] upgraded bluez-libs (5.41-2 -> 5.42-1)
[2016-09-26 13:11] [ALPM] upgraded bluez (5.41-2 -> 5.42-1)

I then downgraded bluez, bluez-libs and bluez-utils to version 5.41-2 and I can now send files from my cell phone and tablet to my notebook again. Hence, I believe there is a problem with version 5.42.1 of Bluez. With that installed bluetooth is functional except for one thing: the computer does not receive files over bluetooth.

Steps to reproduce:

Using version 5.42-1 of bluez, bluez-libs and bluez-utils pair an Android device to the computer and try to send a file from the Android device to the computer (not the other way around).

This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 31 October 2016, 12:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.43
Comment by Andreas Radke (AndyRTR) - Saturday, 08 October 2016, 07:39 GMT
Check git master, git bisect to find the bad commit and file an upstream bug.
Comment by Francisco Cribari (cribari) - Saturday, 08 October 2016, 12:32 GMT
I've filed an upstream bug. I don't have much experience in filing upstream bugs. I hope I did it right. See
Comment by Luis Henrique Mello (lmello) - Tuesday, 11 October 2016, 20:30 GMT
I don't think it's a kernel bug, I'm using LTS kernel (4.4.24) and I having the same issue since the 5.42 upgrade.
Comment by Friedrich Strohmaier (bitsfritz) - Sunday, 16 October 2016, 19:22 GMT
Simply downgrading bluez to 5.41-2 and keeping bluez-libs and bluez-utils at version 5.42-1 also restores ability to receive files here. No other side effects detected.
Comment by Giorgos (ranger) - Sunday, 16 October 2016, 19:36 GMT
I have the same problem, with different laptops and different bluetooths (intel and broadband). Using lts didn't fix the problem.
I'm using 5.41 for the moment and it works fine