Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51269 - [nginx-mainline] Unnecessary GeoIP Module

Attached to Project: Arch Linux
Opened by Ivan Ip (lifehome) - Friday, 07 October 2016, 06:44 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Friday, 18 November 2016, 20:32 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
As nginx 1.11 begins, the officials introduced dynamic module loading, which can drastically decrease the default compiled package to a minimal overhead.
There are already plenty of AUR packages providing the dynamic modules for use, maybe we can utilize them instead?

References: https://www.nginx.com/blog/dynamic-modules-nginx-1-9-11/

Additional info:
* package version(s)
1.11.4-1

* config and/or log files etc.

> Packages (3) geoip-1.6.6-2 geoip-database-20160907-1 nginx-mainline-1.11.4-1
>
> Total Download Size: 1.41 MiB
> Total Installed Size: 4.24 MiB


Steps to reproduce:
Through pacman to install nginx-mainline, and you will find it default with installing geoip packages.
This is unnecessary at all and should not be exist in the default package.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Friday, 18 November 2016, 20:32 GMT
Reason for closing:  Won't implement
Additional comments about closing:  I understand the sentiment. This is something I have on my todo list to bring up on the mailing list, also wrt external modules. Will happen, one day.

Loading...