Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51244 - [perl-crypt-ssleay] module depends on Bytes::Random::Secure

Attached to Project: Arch Linux
Opened by Brian De Wolf (bldewolf) - Wednesday, 05 October 2016, 18:04 GMT
Last edited by Florian Pritz (bluewind) - Saturday, 06 February 2021, 13:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
At some point, Crypt::SSLeay in the perl-crypt-ssleay package started using Bytes::Random::Secure. It is no longer usable without it.

It looks like packages for this new module were prepared in  FS#45811  but they ended up in the AUR.

Additional info:
* perl-crypt-ssleay 0.73_04-4

Steps to reproduce:

$ perl -MCrypt::SSLeay
Can't locate Bytes/Random/Secure.pm in @INC (you may need to install the Bytes::Random::Secure module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/vendor_perl/Crypt/SSLeay.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/Crypt/SSLeay.pm line 8.
Compilation failed in require.
BEGIN failed--compilation aborted.
This task depends upon

Closed by  Florian Pritz (bluewind)
Saturday, 06 February 2021, 13:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in perl-crypt-ssleay-0.73_04-14

Loading...