Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50933 - [prosody] /etc/prosody/certs/ should be 750 root:prosody

Attached to Project: Community Packages
Opened by Link Mauve (linkmauve) - Tuesday, 27 September 2016, 16:15 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 30 September 2016, 08:16 GMT
Task Type Bug Report
Category Security
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
/etc/prosody/certs/ is currently 755, which means any local user can access the certificates by default.

Additional info:
* package version(s)
0.9.10-2
* config and/or log files etc.
N/A

Steps to reproduce:
- Install the prosody package from community.
- ls -ld /etc/prosody/certs is world-readable and executable.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 30 September 2016, 08:16 GMT
Reason for closing:  Not a bug
Additional comments about closing:  or upstream
Comment by Sergej Pupykin (sergej) - Thursday, 29 September 2016, 10:59 GMT
Not sure if it is a bug, but anyway certs directory created by upstream makefile.

Loading...