Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50872 - [xscreensaver] xscreensaver stopped working

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Thursday, 22 September 2016, 17:20 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 06 March 2018, 16:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I don't know quite what has triggered this - or even if this bug is necessarily in the xscreensaver code - but my screen saver has stopped engaging as of about a week ago.

I haven't made changes to the xscreensaver settings in a long time. But I checked them again and they all look correct.


Symptoms:
* Screen saver is supposed to kick in after 1 minute of idle time, but it's not happening.
* I can still invoke the screensaver manually (e.g., using xflock4).
* When I do invoke the screensaver manually, after maybe 30 seconds to 1 minute, the xscreensaver login dialog pops up, as if I had pressed a key or moved the mouse. (Which I hadn't.)
* I suspected perhaps that there's some sort of hardware error on my machine (e.g., stuck keyboard key). But when I leave a console window idle running "xev", it doesn't display any new keyboard or mouse events while I'm idle.
* I'm using XFCE with xscreensaver. I checked to make sure that XFCE is launching the xscreensaver daemon in the background after I log in, and it is. (xscreensaver -no-splash)
* I tried using "watch -n1 xprintidle" to see if my idle time was somehow getting reset, but it doesn't look like it.

I'm not sure what else to check to debug this!?! But this is a big problem, as it my laptop is not being secured every time I walk away from it.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 06 March 2018, 16:38 GMT
Reason for closing:  Not a bug
Comment by David Rosenstrauch (darose) - Monday, 26 September 2016, 14:26 GMT
FYI, I was able to pin this down to an issue with xfce4-power-manager:

https://bugzilla.xfce.org/show_bug.cgi?id=12857

Loading...