FS#50851 - [openresolv] multiple entries in search_domains

Attached to Project: Arch Linux
Opened by Sven Opitz (opitzs) - Wednesday, 21 September 2016, 06:27 GMT
Last edited by Toolybird (Toolybird) - Wednesday, 14 June 2023, 06:53 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


My /etc/resolvconf.conf contains this line:

I execute resolveconf -u and in /etc/resolv.conf I read this
search a.x.com,b.x.com,c.x.com

a test with nslookup confirms, this line doesn't work, it has to be:
search a.x.com b.x.com c.x.com

Spaces instead of commas. I've tried tricking it with the replace command in openresolv (replace="search/,/ /" doesn't do anything) and tried the glibc commands, all expect the parameters comma separated, and then use them comma separated...

Additional info:
* Version: core/openresolv 3.8.1-1

Steps to reproduce:
This task depends upon

Closed by  Toolybird (Toolybird)
Wednesday, 14 June 2023, 06:53 GMT
Reason for closing:  Upstream
Additional comments about closing:  Covered in the Wiki as per comments. Please report upstream if it needs to be in the man page.
Comment by Paul Clark (pdc) - Tuesday, 05 March 2019, 17:37 GMT
According to https://wiki.archlinux.org/index.php/Openresolv#Defining_multiple_values_for_options multiple values can be specified with a space-separated list inside quotes, such as:

search_domains="a.x.com b.x.com c.x.com"