Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50814 - [xf86-video-intel] Screen does not fully redraw while scrolling

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Saturday, 17 September 2016, 14:55 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 19 February 2017, 08:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Scrolling a text document in Leafpad lead to areas of the screen not being redrawn for a little while (seemingly until some other screen update takes place). The symptoms are very similar to  FS#41261 .

This has been a problem for a few weeks now. The last known good version is 1:2.99.917+688+g49daf5d-1.

Probably caused by this upstream commit:
https://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=1f6dfc9df6780bd3768bf065156b6e8dae05b80c

Additional info:
* package version(s)
Any version newer than 1:2.99.917+688+g49daf5d-1.

* config and/or log files etc.

Steps to reproduce:

See description.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 19 February 2017, 08:12 GMT
Reason for closing:  Upstream
Comment by Andreas Radke (AndyRTR) - Saturday, 17 September 2016, 15:07 GMT
Please report it upstream. You can try to revert the related commit or git bisect from the last working pkg.
Comment by John Lindgren (jlindgren) - Saturday, 24 September 2016, 17:28 GMT Comment by John Lindgren (jlindgren) - Saturday, 17 December 2016, 13:33 GMT
It's been 3 months and upstream has still not come up with a working fix. Would you consider reverting the bad commit in the Arch package?
Comment by Andreas Radke (AndyRTR) - Saturday, 18 February 2017, 21:39 GMT
Has this been solved? I'm going to close this one as an upstream bug.
Comment by John Lindgren (jlindgren) - Sunday, 19 February 2017, 01:01 GMT
No it hasn't been solved. I'm still running 1:2.99.917+688+g49daf5d-1 (rebuilt for the newer X server).

I'm going to ask you again to please consider reverting the bad commit. It's widely known that the upstream Intel driver is not stable enough to be distributed as-is.
Comment by John Lindgren (jlindgren) - Sunday, 19 February 2017, 03:29 GMT
Actually don't bother, xorg-server rebuilt with DRI3 disabled + modesetting seems to be a working combination.

Loading...