Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50755 - [freetype2] Environment variables are ignored

Attached to Project: Arch Linux
Opened by Steven Honeyman (stevenhoneyman) - Monday, 12 September 2016, 16:44 GMT
Last edited by Antonio Rojas (arojas) - Monday, 12 September 2016, 16:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

By upgrading freetype2 to 2.7-2, environment variables that should affect it are ignored.

For example, I have attached a screenshot of a couple of browser tabs with "broken" fonts, which appear fine after downgrading to 2.6.5.
In this case 2.7 is ignoring my:
export FT2_SUBPIXEL_HINTING=0 # freetype2

In the Arch forums, others have reported issues with FREETYPE_PROPERTIES also: https://bbs.archlinux.org/viewtopic.php?pid=1653819


Additional info:
* package version(s) - 2.7-2
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 12 September 2016, 16:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Read the post-install messages

Loading...