Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50738 - [NetworkManager] dhclient core dump when trying to get address

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Sunday, 11 September 2016, 13:23 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 17 September 2016, 08:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

It seems that after the last NetworkManager upgrade to version 1.4.1dev, dhclient started dumping core when trying to get an address.
This happens on every boot, until it eventually manages to stay alive and get an IPv4 address.

Obtaining a IPv6 address works fine, since it's done via SLAAC+RDNSS.


Additional info:

networkmanager 1.4.1dev+33+gc87b89b-1
dhclient 4.3.4-2


I tried to extract the relevant bits form my systemd log.

The interesting part is this one:


Sep 11 15:20:21 blue systemd-coredump[1830]: Process 1827 (dhclient) of user 0 dumped core.

Stack trace of thread 1827:
#0 0x00007fc71a0c704f raise (libc.so.6)
#1 0x00007fc71a0c847a abort (libc.so.6)
#2 0x00007fc71a104c50 __libc_message (libc.so.6)
#3 0x00007fc71a18cf17 __fortify_fail (libc.so.6)
#4 0x00007fc71a18b050 __chk_fail (libc.so.6)
#5 0x00007fc71a18a3b2 __strcpy_chk (libc.so.6)
#6 0x000000000042418a n/a (dhclient)
#7 0x000000000040793f n/a (dhclient)
#8 0x00007fc71a0b4291 __libc_start_main (libc.so.6)
#9 0x0000000000408819 n/a (dhclient)

This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 17 September 2016, 08:47 GMT
Reason for closing:  Not a bug
Comment by Jonathan Roemer (pid1) - Monday, 12 September 2016, 23:49 GMT
This sounds like it is happening for you using dhclient instead of the internal DHCP client. Have you isolated this as a bug in NetworkManager specifically?
Comment by Radu Potop (wooptoo) - Tuesday, 13 September 2016, 07:12 GMT
Thanks Jonathan, I wasn't aware there was an internal DHCP client. Is it from the NetworkManager package or from systemd?
And how can I enable that?
Comment by Radu Potop (wooptoo) - Tuesday, 13 September 2016, 07:31 GMT
Managed to fix it. Seems like `internal` is default now and my NetworkManager had an older config with `dhclient`.

Loading...