Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50703 - [linux] [lvm2] resume from hibernation fails with swap on thin lvm

Attached to Project: Arch Linux
Opened by nl6720 (nl6720) - Thursday, 08 September 2016, 11:56 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 27 September 2018, 14:33 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned
Assigned To Tobias Powalowski (tpowa)
Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:
Kernel fails to load hibernation image when swap is on thin volume.

Additional info:
* package version(s)
* config and/or log files etc.

linux 4.7.2-1
lvm2 2.02.164-1

lvs output:
LV VG Attr LSize Pool Origin Data% Meta% Move Log Cpy%Sync Convert
mythinpool VMStorage twi-aotz-- 29,39g 6,96 3,52
thinroot VMStorage Vwi-aotz-- 8,00g mythinpool 25,04
thinswap VMStorage Vwi-aotz-- 4,00g mythinpool 0,91


attached is output of journalctl -lk

Steps to reproduce:

Create thinpool with thin volumes for root and swap.
Add "resume=/path/to/thinswap" to bootloader.
Hibernate.
Try to resume from hibernation.
Fail.
   boot.log (43.4 KiB)
This task depends upon

Comment by nl6720 (nl6720) - Friday, 23 September 2016, 12:49 GMT
Attached is output of journalctl -b
   boot.log (57.8 KiB)
Comment by mattia (nTia89) - Tuesday, 03 October 2017, 20:08 GMT
is this issue still valid?
Comment by nl6720 (nl6720) - Wednesday, 04 October 2017, 09:39 GMT
Still an issue for me.
Comment by mattia (nTia89) - Wednesday, 04 October 2017, 16:13 GMT
unfortunately currently I can't help you directly, but
are you using a virtual machine?

EDIT: could be useful, https://01.org/blogs/rzhang/2015/best-practice-debug-linux-suspend/hibernate-issues
EDIT2: could be linked to this, https://bugs.archlinux.org/task/53422
Comment by nl6720 (nl6720) - Wednesday, 04 October 2017, 18:17 GMT
This is a Virtualbox VM. I prefer to test things in VM before using them on real hardware.
The issue only occurs with swap on thin lvm. I don't recall ever having any issues with hibernating in real or virtual hardware before.

Loading...