Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50697 - [ark] konqueror context menu files missing from ark 16.08.0-1

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Wednesday, 07 September 2016, 18:44 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 07 September 2016, 22:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The previous version of Ark (16.04.3-1) provided a few key files that enabled context menus in konqueror to perform "extract here", "extract here, autodetect subfolder", etc. Those files are missing in ark 16.08.0-1, which removes that functionality from konqueror. This isn't a critical problem, but is a nuisance, as I use that functionality often.

The files in question are:

/usr/share/kservices5/ServiceMenus/ark_addtoservicemenu.desktop
/usr/share/kservices5/ServiceMenus/ark_servicemenu.desktop


Perhaps this is a packaging error and those files can be restored by releasing a package update?
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 07 September 2016, 22:38 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Wednesday, 07 September 2016, 19:05 GMT
No, this is an intended upstream change, not a packaging issue. The service menus still work fine in Dolphin.
It *shouldn't* have worked in konqueror since ark was ported to KF5 in 15.08, unless you were manually symlinking the desktop files to the KDE4 path. In that case, you can just grab the files from the ark 16.04.3 tarball and copy them in the KDE4 service menus path intead of symlinking.
Comment by David Rosenstrauch (darose) - Wednesday, 07 September 2016, 21:49 GMT
Hmmm ... ok. I was symlinking the files, since this broke once before. Obviously I can copy those files from the 16.04.3 tarball to fix this. But I'm confused. Are you saying that this functionality was intentionally removed from konqueror in 15.08 and now only appears in Dolphin? Or is there some other / better way to fix this missing functionality in konqueror? (I.e., besides copying the 2 files from the old tarball.)
Comment by Antonio Rojas (arojas) - Wednesday, 07 September 2016, 22:37 GMT
Nothing was removed from konqueror. Ark was ported to KF5, konqueror is still KDE4, so it can't see ark's service menus. Up to 16.04 the service menus in ark were just simple .desktop text files compatible with KDE4, so it was just a matter of moving them to the right path so that konqueror could see them again. This has changed in 16.08 and the service menus are now binary plugins, so there's no way for konqueror to use them.

This will work again in 16.12 once konqueror is ported to KF5. Until then, you need to copy the old desktop files yourself.

Loading...